Error - EAFNOSUPPORT

shiny-server
#1

Hi,

Not sure what this error is --> listen EAFNOSUPPORT, but shiny server immediatly shuts down. No logs outside of this error. This is a new installation on Redhat linux using Shiny Server v1.5.9.923 (Node.js v8.11.3).

[2018-12-15T00:46:57.580] [INFO] shiny-server - Starting listener on http://[::]:3838
[2018-12-15T00:46:57.586] [ERROR] shiny-server - HTTP server error (http://[::]:3838): listen EAFNOSUPPORT :::3838
[2018-12-15T00:46:57.586] [INFO] shiny-server - Shutting down worker processes
HTTP server error (http://[::]:3838): listen EAFNOSUPPORT

Tried multiple ports with no luck.

Not sure how to fix this...
{
errno: 7,
code: 'EAFNOSUPPORT',
description: 'address family not supported'
},

0 Likes

#2

HI,

I am also getting this same error. Server was working fine until I updated Shiny from version something less that 1.0 up to 1.2, two weeks ago.

Now:
RHEL 7.6,
R 3.3.1,
Shiny Server v1.5.9.923 (Node.js v8.11.3)

Before:
Shiny Server v1.4.6.809 (Node.js v0.10.46)

I tried updating my Node version and now it is 11.4, I'm still getting the same error.

0 Likes

#3

Getting the same error
Please help

0 Likes

#4

Adding the IP address after port worked; didn't find the cause yet.

server {
listen 3838 0.0.0.0;

(please note 0.0.0.0 as per andresrcs notes below)

0 Likes

#5

Thanks it worked after adding ip address

0 Likes

#6

Just to clarify, by modifying the shiny-server config file located at /etc/shiny-server/shiny-server.conf changing this parameter to

server {
  # Instruct this server to listen on port 3838
  listen 1234 127.0.0.1;

You are telling shiny to only allow traffic from your localhost pointing to port 1234, this might not be desirable because you are going to be able to access shiny apps only frome the server itself.

This is especified in the shiny-server administration guide

listen
Directs the enclosing server scope to listen on the specified port/IP address combination.

And the default value for the ip parameter is "* or 0.0.0.0" which accepts all traffic.

0 Likes

#7

Good point. I can correct the post. For this server I was routing external traffic through a nginx server as I'm limited on open ports on the firewall.

0 Likes

#8
0 Likes

closed #9

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

0 Likes