Error HTTP 409 when deploying

Using Rstudio Cloud and

originally my app ran on rstudio cloud. Then I tried to deploy my app to

ran into this error:

The dbplyr package is required to communicate with database backends. Calls: local ... tryCatch -> tryCatchList -> tryCatchOne -> <Anonymous>

then after a while I started getting this error:

Unable to dispatch task for application=1635474, there are 1 tasks in progress

I've looked into the follow forums
Error Deploying to - Database Connection Issue Event
Deploying content to Connect throws 409 Conflict

also my shiny app is connected to BQ as well.

Thank you

I can't offer a specific solution, only a general insight.

HTTP 409 errors roughly translate to

You're asking me to go barefoot with my shoes on!

The server has received a client communication requesting a change of state that isn't provided for in the server-side program logic.

Given your app-specific error message of 1 tasks in progress, I'd try to kill that task and restart the server application and try again.

Thanks. I've run into an issue that when I try to archive or restart the server. I get the same error

Unable to dispatch task for application=1635474, there are 1 tasks in progress

In a post a couple of months ago by @andy_kipp of RStudio, this may be a problem on their end. I'll see if I can get it checked.

It seems like I am encountering a similar problem.
I am trying to deploy my app from Rstudio to
Is there anyway I can kill the task from my end?

Error: HTTP 409
Unable to dispatch task for application=2122162, there are 1 tasks in progress
Execution halted

1 Like

I had the same 409 error, restarted RStudio and deployed again and it worked. Also, when I added the deploy code to the app itself I came out with a few errors, and it worked when I deployed from the console FYI.