Error in file.exists(templateYaml) : "file name conversion problem -- name too long?"

Hello everyone,

I'm experiencing a persistent issue with RStudio on my Windows 11 system and I'm seeking some advice or solutions. My problem is related to the presence of Turkish characters (like ç, Ç, İ) in my Windows username, which seems to be causing path-related errors in RStudio.

Error Message:
The error I encounter is Error in file.exists(templateYaml) :. This error appears immediately upon starting RStudio, without entering any code.

What I've Tried:

Checked R Configuration Files: I've looked into .Rprofile and files for any reference to templateYaml, but found nothing.
Changed the Working Directory in RStudio: I've tried setting the default working directory to a path without Turkish characters via Tools > Global Options > General.
System Locale Settings: I've tried setting the system locale to English, but the issue persists.
Reinstallation: I've also thought about reinstalling R and RStudio, but before doing that, I wanted to seek advice if anyone else has encountered and resolved a similar issue.
Additional Context:
The problem seems to be directly related to the Turkish characters in my Windows username, as the error points to a path under C:\Users\xxxxç Çxxİx\AppData\Roaming\RStudio.

I would greatly appreciate any advice, solutions, or suggestions from the community. Has anyone else faced a similar issue, and if so, how did you resolve it?

Thank you in advance for your help!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.