Error in package installation - "binary source needs compilation"

I haven't run into this problem of installing packages before but I haven't been able to load new packages today. I've tried installing tidyverse, rvest, and reprex but keep hitting the same problem.

This is what I keep seeing:

also installing the dependencies ‘processx’, ‘callr’, ‘fs’

There are binary versions available but the source versions are later:
binary source needs_compilation
processx 3.3.0 3.4.1 TRUE
callr 3.1.1 3.4.1 FALSE
fs 1.2.6 1.3.1 TRUE
reprex 0.2.1 0.3.0 FALSE

Do you want to install from sources the packages which need compilation? (Yes/no/cancel)
installing the source packages ‘processx’, ‘callr’, ‘fs’, ‘reprex’

After saying yes, a ton of code is produced that says things like "trying URL ...", "Warning in install.packages" and "ERROR: dependencies not available for package"

Finally the code will stop at:
The downloaded source packages are in

However, when I run the library command, it will say that there is no such package loaded.

I initially saw that the error could be due to using an outdated version of R but I'm currently using version 3.5.3 and don't think that's the problem.

Any insight as to why these issues are occurring would be super appreciated!! Thanks!

We would need to see the error messages to see what is going on but very likely you are having issues compiling packages from source, one way to avoid this is to update R to the latest version (3.6.2) so you have access to binary versions which don't need compiling. If this doesn't work then post the whole error message so we can give you better advice.

That worked! Thank you!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.