Error in py_convert_pandas_df(x)


I have a fresh Rstudio where i want to work with some data which come from python scripts. On RStudio I installed: tidyverse, openxlsx, xlsx, data.table, janitor, anytime, tinytex, zoo, ggrepel, gridExtra, reticulate, rmarkdown, kableExtra, dplyr,

run the following:

And although i had anaconda3 installed on my computer, rstudio didn't recognize it, I got the following:
No non-system installation of Python could be found.
Would you like to download and install Miniconda?
Miniconda is an open source environment management system for Python.
See for more details.

Would you like to install Miniconda? [Y/n]: Y

After I installed:
environment location: C:\Users\nora\AppData\Local\r-miniconda\envs\r-reticulate

added / updated specs:
- numpy
- python=3.6

Then installed numpy, pandas, xlrd with the following method:

And when I try to run the following part:
for(py_file in py_files) reticulate::source_python(paste0(project_folder, py_file))

I got this error message:
Error in py_convert_pandas_df(x) :
SystemError: <built-in method item of numpy.ndarray object at 0x000001CEE400AA30> returned a result with an error set

After two days of debugging this mysterious error code any help would be appreciated. I already tried to reinstall r, rstudio, python and ot the same error.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.