ERROR: lazy loading failed for package 'broom'

I'm trying to install tidyverse, is my first time using RStudio, when I execute: install.packages("tidyverse")

Apparently install all except "broom"

And then when I try yo run: library(tidyverse)

I receive this errors:

Error in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]) : 
  there is no package called 'zeallot'
Calls: <Anonymous> ... loadNamespace -> withRestarts -> withOneRestart -> doWithOneRestart
Ejecución interrumpida
ERROR: lazy loading failed for package 'broom'
* removing 'C:/Program Files/R/R-3.6.2/library/broom'
Warning in install.packages :
  installation of package ‘broom’ had non-zero exit status

You are missing this package dependency, try installing it first and see how it goes

1 Like

Thanks a lot, this solved the issue!

Thanks andresrcs. Weird, I had a similar issue today (28/01/2020, New Zealand) which did not exist yesterday, requiring install.packages("zeallot") to successful call library("tidyverse")

Interesting, I also have the same issue today too. Installing "zeallot" solved the issue.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.