Error loading tydeverse

I had the following error msg trying load tidyverse:

Error: package or namespace load failed for ‘tidyverse’ in dyn.load(file, DLLpath = DLLpath, ...):
impossível carregar objeto compartilhado '/home/usuario/R/x86_64-pc-linux-gnu-library/4.1/xml2/libs/':
/home/usuario/R/x86_64-pc-linux-gnu-library/4.1/xml2/libs/ symbol htmlReadFile version LIBXML2_2.6.0 not defined in file with link time reference

Any help to solve it?


it seems you are on a linux system, I think you may need to install Libxml2 as a system utility before retrying your R installs.

Yes I am using linux debian. The Libxml2 was already installed but the error remains. And I realized that KableExtra shows the same error when loaded.

Try to install in R


It would be better if you clarify that you have made this question before and that you already have tried some things so people don't waste time suggesting the same things again.

1 Like

Sorry Andes, it is not new to me only use R, but also participate in a Community like this.

Any way I still need help to find a solution.

I updated the R to 4.1 version as well the packages Tidyverse and Xml2, including removing and reinstalling with no results.

As I said, I realized that KableExtra shows the same msg when loaded.

Tks for any new idea.

poster raised issue on xlm2's github, which is probably the approach most likely to get a positive outcome.
Error loading xml2 · Issue #343 · r-lib/xml2 (

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.