Error loanding a package

Hello, I have a problem when loading the "RPushbullet" package. The weird thing is that I have used it before but now I cannot. I have tried desinstalling it, removing it manually, executing it in R, installing the new update of R but I still cannot solve it. I have also tried in another computer and I was able tod run my code without problems. This is the error that appears:

Error: package or namespace load failed for ‘RPushbullet’:
.onLoad failed in loadNamespace() for 'RPushbullet', details:
call: parse_con(txt, bigint_as_char)
error: parse error: premature EOF

                 (right here) ------^

I have Windows 10
Can somebody help me? Thank you

Hard to say without knowing your operating system. I just installed in Mojave and Ubuntu from a CRAN mirror without that message. Are you on Windows?

I have installed and loaded on windows 10 and not getting the same message, but I suspect that your problem is with the JSON file that holds your API credentials.

#> package 'RPushbullet' successfully unpacked and MD5 sums checked
#> The downloaded binary packages are in
#>  C:\Users\andre\AppData\Local\Temp\Rtmp6pNa5E\downloaded_packages
#> Attaching RPushbullet version 0.3.1.
#> No file ~/.rpushbullet.json found. Consider placing the Pushbullet
#> API key and your device id(s) there.

Created on 2019-02-17 by the reprex package (v0.2.1)

1 Like

This topic was automatically closed 54 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.