Error message at startup about DOSKEY

When RStudio starts up (2023.09.0 Build 463, with R 4.3.1, Windows 10), without a project open, it gives me the same error message twice, "'DOSKEY' is not recognized as an internal or external command,
operable program or batch file." This is just after it has said "[Workspace loaded from ~/.RData]", if there is an .RData. (I cleared the environment and restarted RStudio - same error messages. I deleted .RData, still the same error messages though obviously not after the one about loading the workspace because there was no workspace to load.) The error message doesn't appear if I have a project open, but it reappears as soon as I close the project. Also it doesn't happen if I run R directly instead of through RStudio. It only started after I upgraded RStudio to the current version, about a week ago. So I assume it's an RStudio thing, and a new one.

I don't know whether it matters - everything else seems to work. My concern is that I don't know where it is coming from, because I haven't found anything that is trying to run DOSKEY, and that it may cause some error in something else that I'll fail to spot. Any clues?

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.