Error message RStudio is damaged and can’t be opened. You should move it to the Trash

Hi, I am new to using R and R-studio. Please help me.....
Everything was working fine until Rstudio Crashed 2 days back. And I have tried a bunch of things but nothing works. Whenever I try opening it a box with a yellow exclamation mark under the R sign appears. I tried re-installing it and followed all suggestions on this page ( but nothing works. When I try re-installing from a new download if I try opening the RStudio-1.1.463.dmg folder the message " “RStudio-1.1.463.dmg” is damaged and can’t be opened. You should move it to the Trash." appears. My computer is using a MacOS Mojave 10.14.2 and my R info from the terminal is the following:

R version 3.5.1 (2018-07-02)
Platform: x86_64-apple-darwin15.6.0 (64-bit)
Running under: macOS 10.14.2
Matrix products: default
BLAS: /Library/Frameworks/R.framework/Versions/3.5/Resources/lib/libRblas.0.dylib
LAPACK: /Library/Frameworks/R.framework/Versions/3.5/Resources/lib/libRlapack.dylib
[1] en_US.UTF-8/en_US.UTF-8/en_US.UTF-8/C/en_US.UTF-8/en_US.UTF-8

attached base packages:
[1] stats graphics grDevices utils datasets methods base

loaded via a namespace (and not attached):
[1] compiler_3.5.1

Please help me
Thank you

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.