Error: object 'M' not found using Bibliometrix

Hi everyone! I just started using R so I dont know much. I need help:

I've been trying to upload a .bib file obtained from Scopus, into biblioshiny(). Once I press start, this is what I get in R console:

Warning: Error in ..stacktraceon..: object 'M' not found
104: isolate
103: exprFunc [/home/rstudio-user/R/x86_64-pc-linux-gnu-library/3.6/bibliometrix/biblioshiny/server.R#63]
102: widgetFunc
101: func
88: origRenderFunc
87: renderFunc
83: origRenderFunc
82: output$contents
2: runApp
1: biblioshiny

Does someone know what can I do? Am I lacking any package? The .bib file is OK, I tried it on a professors computer.

Thank you very much.

Hi, and welcome.

Could you post this as a reproducible example, called a reprex, please. That makes it a lot easier to troubleshoot. Here's an example based on the vignette

#> To cite bibliometrix in publications, please use:
#> Aria, M. & Cuccurullo, C. (2017) bibliometrix: An R-tool for comprehensive science mapping analysis, Journal of Informetrics, 11(4), pp 959-975, Elsevier.
#> http:\\
#> To start with the shiny web-interface, please digit:
#> biblioshiny()
D <- readFiles("")
M <- convert2df(D, dbsource = "isi", format = "bibtex")
#> Converting your isi collection into a bibliographic dataframe
#> Articles extracted   100 
#> Articles extracted   200 
#> Articles extracted   291 
#> Done!
#> Generating affiliation field tag AU_UN from C1:  Done!
#> [1] "[ANONYMOUS], 2013, GUARDIAN.;KETEFIAN S, 2009, INT J NURS STUD, V46, P751, DOI 10.1016/J.IJNURSTU.2008.08.009.;STEFANIAK B, 2001, SCIENTOMETRICS, V52, P193, DOI 10.1023/A:1017959605687.;FITZPATRICK JJ, 2013, APPL NURS RES, V26, P49, DOI 10.1016/J.APNR.2013.02.002.;POLIT DF, 2011, NURS OUTLOOK, V59, P18, DOI 10.1016/J.OUTLOOK.2010.11.001.;LEE S, 2005, SOC STUD SCI, V35, P673, DOI 10.1177/0306312705052359.;CLARK AM, 2012, J ADV NURS, V68, P2373, DOI 10.1111/J.1365-2648.2012.06081.X.;GALLAGHER A, 2011, NURS ETHICS, V18, P3, DOI 10.1177/0969733010388353.;SMITH DR, 2011, NURS HEALTH SCI, V13, P384, DOI 10.1111/J.1442-2018.2011.00652.X.;VAUGHAN L, 2005, J AM SOC INF SCI TEC, V56, P1075, DOI 10.1002/ASI.20199.;JOHNSTONE MJ, 2007, INT NURS REV, V54, P35, DOI 10.1111/J.1466-7657.2007.00527.X.;DE GROOTE SL, 2012, NURS OUTLOOK, V60, P391, DOI 10.1016/J.OUTLOOK.2012.04.007.;CLARK A.M., 2015, J ADV NURS, V71, P1.;MOLZAHN AE, 2015, NURS EDUC TODAY, V35, P9, DOI 10.1016/J.NEDT.2014.07.004.;THOMSON P, 2006, HELPING DOCTORAL STU."

Created on 2019-11-28 by the reprex package (v0.3.0)

Hi technocrat. Thanks for answering. I've been trying to use reprex in my post, as you demanded, but I'm also having problems with this hahaha. I keep recieving the line:

No input provided and clipboard is not available

and also:

Error: Clipboard on X11 requires 'xclip' (recommended) or 'xsel'.

Im using Windows and I just followed instructions. Whats xclip and how can I get it?
Sorry about being so newbie hahah I will learn,

thanks a lot

1 Like

Are you using RStudio Server or RStudio Cloud?, if so, then you would not be able to access to the clipboard, a walk-around could be to select the code you want to reprex and then run reprex::reprex_selection() in the console.

1 Like

Hi. I've been using RStudio Cloud so far.
How do I run code keeping something selected?

Thank you for using your time for helping me, I really appreciate

1 Like

type the code you want to reprex on the "source" pane, select it, and then run reprex::reprex_selection() on the "console" pane.

1 Like

Hahaha sorry andresrcs, more trouble:

Removing leading prompts from reprex source.
Rendering reprex...
Error: callr subprocess failed: :20:11: unexpected symbol
20: Listening on

Sorry if I can not send you a reprex for asking help, I dont want to waste your time

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.