Error of initial submission of new package to CRAN using devtools::submit_cran()

Hi there,

I just tried submitting a new package to CRAN using devtools::submit_cran() and received the following error:

Error in if (new_url$query$submit == "1") { : argument is of length zero

Any idea what the issue could be? I couldn't find anything on the web.

Many thanks!

Ps: Here is my sessionInfo():

R version 4.2.1 (2022-06-23)
Platform: x86_64-apple-darwin17.0 (64-bit)
Running under: macOS Ventura 13.4.1

Matrix products: default
LAPACK: /Library/Frameworks/R.framework/Versions/4.2/Resources/lib/libRlapack.dylib

[1] en_US.UTF-8/en_US.UTF-8/en_US.UTF-8/C/en_US.UTF-8/en_US.UTF-8

attached base packages:
[1] stats graphics grDevices datasets utils methods base

other attached packages:
[1] devtools_2.4.5.9000 usethis_2.2.2

loaded via a namespace (and not attached):
[1] Rcpp_1.0.11 compiler_4.2.1 pillar_1.9.0 later_1.3.1 urlchecker_1.0.1 prettyunits_1.1.1 profvis_0.3.8 remotes_2.4.2 tools_4.2.1
[10] digest_0.6.33 pkgbuild_1.4.2 pkgload_1.3.2.1 memoise_2.0.1 lifecycle_1.0.3 tibble_3.2.1 pkgconfig_2.0.3 rlang_1.1.1 shiny_1.7.4.1
[19] cli_3.6.1 rstudioapi_0.15.0 curl_5.0.1 fastmap_1.1.1 httr_1.4.6 stringr_1.5.0 desc_1.4.2 fs_1.6.2 vctrs_0.6.3
[28] htmlwidgets_1.6.2 rprojroot_2.0.3 glue_1.6.2 R6_2.5.1 processx_3.8.2 fansi_1.0.4 sessioninfo_1.2.2 callr_3.7.3 purrr_1.0.1
[37] magrittr_2.0.3 promises_1.2.0.1 ps_1.7.5 ellipsis_0.3.2 htmltools_0.5.5 mime_0.12 xtable_1.8-4 renv_0.16.0 httpuv_1.6.11
[46] utf8_1.2.3 stringi_1.7.12 miniUI_0.1.1.1 cachem_1.0.8 crayon_1.5.2

@JWeberpals this might be due to problems at CRAN see Henrik Bengtsson: "📢 CRAN Team announcement (2023-07-12): CRAN subm…" - Mastodon

:loudspeaker: CRAN Team announcement (2023-07-12):

CRAN submissions not possible due to issues - you'll see "Unpacking failed. Please make sure the tar.gz was created with R CMD build"

CRAN incoming queue: 2 days delay right now

CRAN submission summer break: Jul 21-Aug 7, 2023

1 Like

@maelle Thank you very much, this explains it (I got exactly that error message when I tried alternatively submitting it via CRAN upload).

1 Like

This topic was automatically closed after 45 days. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.