Error on JSONIO package update

package-installation

#1

Update of JSONIO fails.

The only error message that I can find is:

rlibjson.c:463:5: error: unknown type name 'JSONSTREAM'
JSONSTREAM *stream;
^

I can't find any information on Google about this error. Any explanation or suggestions as to how I can fix this?

Thanks in advance for any help.

Larry Hunsicker


#2

I don't know the reason for this error, but you can/should probably switch to a different json parsing package. I can recommend jsonlite for that.
RJSONIO hasn't been updated for more than 4 years so things ought to go wrong.


#3

Thanks, Misha. I have loaded jsonlite successfully and deleted RJSONIO. That obviously removes the RJSONIO update problem.

Larry Hunsicker


#4

If your question's been answered (even by you!), would you mind choosing a solution? It helps other people see which questions still need help, or find solutions if they have similar problems. Here’s how to do it: