Error: Package 'tcltk' could not be loaded, execution halted

Hi, I have an r code that runs but i am trying to transfer it to an r markdown. When loading and knitting the packages (the first code junk) , it says Error: Package 'tcltk' could not be loaded, execution halted. I tried to include the package as well and still got the same error. Any ideas? I'm working on a macbook air.

It means there is something not right with the tcltk package. You need to look into this on your environment.

Small hints: this package is used to create some user interface usually, and is usually used for interactive session. When you render a Rmd document, it will be in a non-interactive session, and you can't execute a function into a chunk that will need to open a window or something else.

Without any example of what you tried, we won't be able to help much more.
Please share an example of what you tried.

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.