Error: package ‘xts’ required by ‘quantmod’ could not be found

hi all,
i am trying to make an interactive map using leaflet library
when I add this line to the code:
addLegend(position = "bottomright", pal = qpal, values =~resultsvalue)%>%
and try to run the app this error shows up:
Error: package ‘xts’ required by ‘quantmod’ could not be found

i tried to install xts and quantmod but still getting the same error

appreciate your help
ahmed ali
PhD in architecture

Do you get any error message when you try to install this libraries? and more importantly, could you prepare a reproducible example (reprex) illustrating your issue? Please have a look at this guide, to see how to create one for a shiny app

1 Like