ERROR system error 2 (Fatal error) upon opening RStuio - SessionCpp.R not found


I've experienced a fatal error on multiple occasions upon opening RStudio. When trying to open RStudio nothing really happens (the program opens, but nothing is loaded).
I get the R Message below:


I am able to uninstall RStudio and reinstall it (I've done so for three consecutive days now), but as soon as I close the program, I am unable to re-open it.

System details:
RStudio version: 2022.07.1-554
Base R: Rx64 4.1.3

I am able to upen Base R just fine.

Any help would be appreciated. Thanks in advance!



This is not a solution, but I can see your system is in danish. I assume you are using windows? I am also using a danish windows and I get the same error. Maybe it has something to do with the language of the system? I will add that the requested file "SessionsCpp.R" does not exist in my modules folder.

I hope someone can help.

All the best.

I haven't solved the issue, but using an older version of Rstudio stopped the issue for me. You can try that.

I have the same issue, also on a Danish system.
Which RStudio version did you succesfully downgrade to?

RStudio 2022.02.0+443 "Prairie Trillium" . Link to download. But I didn't check to see if a newer version worked, I just picked an old version, so maybe a newer version of 2022.02.x works. Best of luck.

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.