Error when expanding Oracle tables in Connections pane

I'm using odbc on a Windows 10 machine to connect R to our Oracle datawarehouse.

I can connect and use dplyr in the console just fine. However, if use the RStudio Connections pane, I'm able to see all the schemas and tables, but when I try to expand a table to see the columns in that table, I get an error.

First, RStudio pops up a dialog box saying "R code execution error"

Then, in the console, I see more details about the error, namely:

Error in connection_sql_columns(connection@ptr, table_name = validateObjectName(table,  : 
  nanodbc/nanodbc.cpp:2593: HY004: [Oracle][ODBC]Invalid SQL data type <-25>. 

Based on that error, I'm assuming there's some sort of problem translating the data types from Oracle to RStudio. I get this on every table I've tried (though, to be fair, I haven't tried every table in the database). I don't run into this error if I try collecting rows from the table--I can pull them into memory just fine and even print the standard few rows without collecting.

Suggestions on what I might need to fix?

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.