Error when loading package mosaic

Dear all,

I have big troubles with the error "there is no package called pillar". I receive this, when I try to import my CSV dataframe. I had no problems in the past and now I found out, that it seems to be connected with the package "mosaic" (see below).

Please help me! What do I have to do?

Lade nötiges Paket: dplyr
Error: package or namespace load failed for ‘dplyr’ in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
es gibt kein Paket namens ‘pillar’
Fehler: Paket ‘dplyr’ konnte nicht geladen werden
Zusätzlich: Warnmeldungen:
1: Paket ‘mosaic’ wurde unter R Version 3.4.4 erstellt
2: Paket ‘dplyr’ wurde unter R Version 3.4.4 erstellt

Have you already tried installing the missing package?


Do you get any error message while doing so?


Thanks for your reply. I tried already and Iam always installing the package, what the error message asking me to do. I really have no idea what still to do. I have the latest update vom R Studio, I also installed RTool40 and did the check if its fully running. So, I really don´t know what I still can do or what the problem is....

Please post the complete output message you get when you run this command



Thanks for your message. This is the output:

WARNING: Rtools is required to build R packages but is not currently installed. Please download and install the appropriate version of Rtools before proceeding:
also installing the dependencies ‘rlang’, ‘ellipsis’, ‘lifecycle’, ‘vctrs’

There are binary versions available but the source versions are
binary source needs_compilation
rlang 0.3.4 0.4.11 TRUE
ellipsis 0.1.0 0.3.2 TRUE
vctrs 0.1.0 0.3.8 TRUE
pillar 1.3.1 1.6.1 FALSE

Do you want to install from sources the packages which need compilation?

I actually downloaded and installed the Rtools from here:

This is the check:

Installing "rlang" comes also with the same error and requiring the Rtools. "ellipsis" is running, "lifecycle" comes with the same error like "rlang" and "vctrs" the same.....

Do you see any other issue?

Well that is not the complete output, but I think I know what your problem is, RTools40 is for being used with R >= 4.0.0 and since you are using a much older version you need to install a suitable RTools version from here

Or, update your R version (current stable version is 4.1.0), with the additional benefit of getting access to precompiled binaries for the latest package versions.

Hi again,

Meanwhile I am really upse and dont know what else I can do!!!!! No matter which package I try to install, the system warns me to install the appropriate version of R Tools, what I did already. I did the check to see, if "make" can be found:


I am running the latest R Studio version, so it should match, right?????!!!!!!!

I have to finish my bachelor thesis and have no clue anymore what else I can do. Nobody around can help me, even the university says, I have to talk with guys from "R"....

So here I am again with a SOS!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Thanks in advance

When dealing with technical stuff you need to be very specific, what version of R are you running? (you can share the output of sessioninfo()) and what specific version of RTools have you installed?

Here maybe more specific:

sessionInfo (package = NULL)
R version 3.4.2 (2017-09-28)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows 7 x64 (build 7601) Service Pack 1

Matrix products: default

[1] LC_COLLATE=German_Germany.1252 LC_CTYPE=German_Germany.1252
[3] LC_MONETARY=German_Germany.1252 LC_NUMERIC=C
[5] LC_TIME=German_Germany.1252

attached base packages:
[1] stats graphics grDevices utils datasets methods base

loaded via a namespace (and not attached):
[1] compiler_3.4.2 tools_3.4.2 tinytex_0.10 xfun_0.4

You are not using the latest R version, this one is very old (as I said before, latest is 4.1.0) and you are not specifying which RTools version you have installed so I can't tell if they match.

You can download the latest R version from here

And then install the matching RTools40, but there is a chance you might not even need RTools after updating R.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.