Error when trying to install packages

Hello! I am trying to install a package and I keep getting this error.

sh: tar: command not found
Warning in install.packages :
error in running command
Warning in install.packages :
'tar' returned non-zero exit code 127
Error in install.packages : file ‘/var/folders/g6/9d86qz250bg1gljtx5qdjmkc0000gn/T//RtmpW9oRYH/downloaded_packages/Matrix_1.5-3.tgz’ is not a macOS binary package

I am on an M1 Mac, OS 11.2.3 and everything should be up to date. Anyone know how to fix this?

Do those two possibilities help?

Hi Alexis,

Those two possibilities did not help at all.
I set aside the project I was working on and started some dialog with the package developer.
A few weeks later I decided to try again, and the script performed perfectly.

I believe the solution was in the original package.
Apple's switch to the M series chip created a great deal of software decoding that has taken awhile to migrate through the software community.

I appreciate the dedication of the CRAN developers to keep the software up-to-date in a reasonable time.

Thanks for asking