Error while installing "car" library. Same error for "textdata"

This has usually not been an issue but when I restarted my computer and loaded my libraries I gor the following error. Please help!

library(car)
Error: package or namespace load failed for ‘car’ in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]):
namespace ‘vctrs’ 0.2.0 is already loaded, but >= 0.2.1 is required
In addition: Warning message:
package ‘car’ was built under R version 3.6.3

library(textdata)
Error: package or namespace load failed for ‘textdata’ in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]):
namespace ‘vctrs’ 0.2.0 is already loaded, but >= 0.2.1 is required
In addition: Warning message:
package ‘textdata’ was built under R version 3.6.3

You are been asked to update vctrs package

install.packages("vctrs") 

Thank you!! I did that and now get the following error. Could you please advice me here?

Error: package or namespace load failed for ‘textdata’ in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]):
namespace ‘rlang’ 0.4.0 is already loaded, but >= 0.4.5 is required
In addition: Warning message:
package ‘textdata’ was built under R version 3.6.3

Your package library is independent from your R installation. Try to install rlang again and post here the whole message output you get.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

Same problem, different package, update the required packages as needed.

install.packages("rlang")

Same problem here. I have re-installed R, deleted car and re-installed it, used install.packages("rlang"), followed with library(car), and get the same error:

library(car)
Error: package or namespace load failed for ‘car’ in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]):
namespace ‘rlang’ 0.4.0 is already loaded, but >= 0.4.5 is required

I am using R 3.6.3.

Is this required for car functions to work? I had the same error when I tried to run a correlation plot (ggpairs), so rlang must work in ggplot2 as well.

What message output do you get when you try to install rlang? If you keep getting asked to update rlang then you haven't properly updated it.

How do you update it separately from re-installing R (now 3.6.3)? I removed all previous versions of R, downloaded the newest one (3.6.3), then installed the package car (install.packages ("car")).
The error message popped up again: > library(car)

Loading required package: carData
Error: package or namespace load failed for ‘car’ in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]):

namespace ‘rlang’ 0.4.0 is already loaded, but >= 0.4.5 is required
I have gone into the temp files and can see rlang 0.4.5, so obviously it has been loaded
Any thoughts are welcome! I have wasted an entire day and night on this, when there is probably some easy fix. Thanks in advance.