error while rendering quarto to pdf file

Can someone help me find a solution to this error message?

==> quarto preview index.qmd --to pdf --no-watch-inputs --no-browse

processing file: index.qmd

output file: index.knit.md

pandoc
to: latex
output-file: index.tex
standalone: true
pdf-engine: xelatex
variables:
graphics: true
tables: true
default-image-extension: pdf

metadata
documentclass: scrartcl
classoption:
- DIV=11
- numbers=noendperiod
papersize: letter
header-includes:
- '\KOMAoption{captions}{tableheading}'
block-headings: true
title: 'Hello, Penguins'
subtitle: Get Started with Quarto
editor: visual
bibliography:
- references.bib

running xelatex - 1
This is XeTeX, Version 3.141592653-2.6-0.999993 (TeX Live 2021/W32TeX) (preloaded format=xelatex)
restricted \write18 enabled.
entering extended mode

updating tlmgr

updating existing packages
finding package for scrartcl.cls

compilation failed- no matching packages
LaTeX Error: File `scrartcl.cls' not found.

Type X to quit or to proceed,
or enter new name. (Default extension: cls)

Enter file name:
! Emergency stop.
<read *>

l.10 ^^M

Could you supply the yaml text for this document?

Thank you for rthe quick reply. Here it is.

title: "Hello, Penguins"
subtitle: "Get Started with Quarto"
format: pdf
editor: visual
execute:
echo: true
bibliography: references.bib

In addition, I got this as part of the error message I shared but I didn't share it earlier since it has my personal information. I will replace my user name with "xxxxx". I hope this helps.
"see C:\Users\xxxxx\OneDrive - Cal Poly Pomona\Documents\Work\Jaemin\4. Teaching\Center Internship Program\IBM4192\Course Materials\2-1. Data Science\7.0. Create a Report with Quarto\index.log for more information."

This is a bit of a guess but I think you need to include a call to the koma-script LaTeX package in your Yaml.

This might work,

title: "Hello, Penguins"
subtitle: "Get Started with Quarto"
header-includes:
  - \usepackage{koma-script}
format: pdf
editor: visual
bibliography: references.bib
header-includes:

It looks like scrartcl.cls may be a subset of {koma-script},

Unfortunately, it it didin't work. Below is my yml and error message.

title: "Hello, Penguins"
subtitle: "Get Started with Quarto"
header-includes:

  • \usepackage{koma-script}
    format: pdf
    editor: visual
    execute:
    echo: true
    bibliography: references.bib

andoc
to: latex
output-file: index.tex
standalone: true
pdf-engine: xelatex
variables:
graphics: true
tables: true
default-image-extension: pdf

metadata
documentclass: scrartcl
classoption:
- DIV=11
- numbers=noendperiod
papersize: letter
header-includes:
- '\KOMAoption{captions}{tableheading}'
- '\usepackage{koma-script}'
block-headings: true
title: 'Hello, Penguins'
subtitle: Get Started with Quarto
editor: visual
bibliography:
- references.bib

running xelatex - 1
This is XeTeX, Version 3.141592653-2.6-0.999993 (TeX Live 2021/W32TeX) (preloaded format=xelatex)
restricted \write18 enabled.
entering extended mode

updating tlmgr

updating existing packages
finding package for scrartcl.cls

compilation failed- no matching packages
LaTeX Error: File `scrartcl.cls' not found.

Type X to quit or to proceed,
or enter new name. (Default extension: cls)

Enter file name:
! Emergency stop.
<read *>

l.10 ^^M

Okay, then we need to see all of your code. What Latex installation do you have?

Something in the text body seems to be calling scrartcl and if I am reading this correctly it should be in koma-script. Perhaps someone with a better knowledge of LaTeX packages can comment.

This works:

---
title: "Hello, Penguins"
subtitle: "Get Started with Quarto"
format: pdf
editor: visual
execute:
   echo: true
bibliography: references.bib
---

The penguins in Greenland are very elusive birds. 


Thank you for the feedback. I am not familiar with Latex. I haven't used it much. When I use rmd file or quarto, I have been avoiding rendering it for pdf file because I had some trouble. I predominantly used HTML rendering, but I wanted to learn how to post on quarto pub site and make a different file format version other than HTML.

I have used Latex for years but I am not terribly competent with it. In any case , we really need to see your complete text to see where you are making a call to scrartcl

It is not something one would do it a basic Quarto document.

Thank you for your time.

Hi @bluesky
Looks to me like you need to install either Texlive or MikTex to replace xelatex.

I'd say that is a good idea. I have a full TeXLive installation which functions well.

Should I install them within RStudio? Or do I install them independently? I thought the latter was the case when I searched for TeXLive. I wanted to confirm before I do. Thanks!

I solved the problem by following quarto's website guide: Quarto – PDF Engines.
In the RStduio terminal, I ran this code: quarto install tinytex --update-path.
This solved the problem. Thank you so much for the suggestions.

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.