Exceptionally slow to open RStudio and package manager

packagemanagement
ide
start-up

#1

Error Information:

Description of issue -
I am using RStudio on my university standard operating environment PC. In December I upgraded my R version to R 3.5.1 and RStudio to Version 1.1.456. After this I did several analyses and all was fine. Yesterday I returned after the Christmas break and found that RStudio was taking 5 minutes to load. When it is loaded I can run previously written code but if I try to switch into the package manager I get a never ending progress wheel. I have provided the diagnostic report after loading RStudio, I cannot generate one after trying to access the package manager. I found an article suggesting installing the daily build but unfortunately I can't do that because I can only access the builds packaged in our SOE. Any suggestions would be much appreciated.

Attempted steps taken to fix -

System Information:

  • RStudio Edition: Desktop
  • RStudio Version: 1.1.456
  • OS Version: Windows 8.1 enterprise
  • R Version: 3.5.1
  • Output your diagnostics report (if possible):

[1] "1.1.456"

$R
[1] "M:\\R Statistics\\R-3.5.1\\bin\\x64\\R.exe"

$pdflatex
[1] ""

$bibtex
[1] ""

$gcc
[1] ""

$git
[1] ""

$svn
[1] ""

R version 3.5.1 (2018-07-02)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows >= 8 x64 (build 9200)

Matrix products: default

locale:
[1] LC_COLLATE=English_United Kingdom.1252  LC_CTYPE=English_United Kingdom.1252   
[3] LC_MONETARY=English_United Kingdom.1252 LC_NUMERIC=C                           
[5] LC_TIME=English_United Kingdom.1252    

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

loaded via a namespace (and not attached):
[1] compiler_3.5.1 tools_3.5.1    yaml_2.2.0    

SysInfo:
       sysname        release        version       nodename        machine          login           user 
     "Windows"     ">= 8 x64"   "build 9200"   "KCLJ8ZFF62"       "x86-64"     "k1634825"     "k1634825" 
effective_user 
    "k1634825" 

R Version:
               _                           
platform       x86_64-w64-mingw32          
arch           x86_64                      
os             mingw32                     
system         x86_64, mingw32             
status                                     
major          3                           
minor          5.1                         
year           2018                        
month          07                          
day            02                          
svn rev        74947                       
language       R                           
version.string R version 3.5.1 (2018-07-02)
nickname       Feather Spray               
$ALLUSERSPROFILE
[1] "C:\\ProgramData"

$APPDATA
[1] "C:\\Users\\k1634825\\AppData\\Roaming"

$CLICOLOR_FORCE
[1] "1"

$CommonProgramFiles
[1] "C:\\Program Files\\Common Files"

$`CommonProgramFiles(x86)`
[1] "C:\\Program Files (x86)\\Common Files"

$CommonProgramW6432
[1] "C:\\Program Files\\Common Files"

$COMPUTERNAME
[1] "KCLJ8ZFF62"

$ComSpec
[1] "C:\\WINDOWS\\system32\\cmd.exe"

$DISPLAY
[1] ":0"

$FP_NO_HOST_CHECK
[1] "NO"

$GFORTRAN_STDERR_UNIT
[1] "-1"

$GFORTRAN_STDOUT_UNIT
[1] "-1"

$HOME
[1] "//kclad.ds.kcl.ac.uk/anywhere/UserData/PSStore01/k1634825/My Documents"

$HOMEDRIVE
[1] "N:"

$HOMEPATH
[1] "\\"

$HOMESHARE
[1] "\\\\kclad.ds.kcl.ac.uk\\anywhere\\UserData\\PSStore01\\k1634825"

$KCLLogs
[1] "C:\\ProgramData\\KCL\\Logs"

$LOCALAPPDATA
[1] "C:\\Users\\k1634825\\AppData\\Local"

$LOGONSERVER
[1] "\\\\KCLGUYCDC01"

$MSYS2_ENV_CONV_EXCL
[1] "R_ARCH"

$NUMBER_OF_PROCESSORS
[1] "4"

$OneDrive
[1] "C:\\Users\\k1634825\\OneDrive - King's College London"

$OneDriveCommercial
[1] "C:\\Users\\k1634825\\OneDrive - King's College London"

$OS
[1] "Windows_NT"

$PATH
[1] "M:\\R Statistics\\R-3.5.1\\bin\\x64;C:\\Program Files (x86)\\Common Files\\Oracle\\Java\\javapath;C:\\ProgramData\\Oracle\\Java\\javapath;C:\\WINDOWS\\system32;C:\\WINDOWS;C:\\WINDOWS\\System32\\Wbem;C:\\WINDOWS\\System32\\WindowsPowerShell\\v1.0\\;M:\\pcraster-4.0.2_x86-64\\bin;M:\\pcraster-4.0.2_x86-64\\python;C:\\Program Files (x86)\\QuickTime\\QTSystem\\;C:\\AppliedBiosystems\\SDS2.4\\lib\\algorithm\\bin\\win32;C:\\AppliedBiosystems\\SDS2.4\\lib"

$PATHEXT
[1] ".COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC"

$PROCESSOR_ARCHITECTURE
[1] "AMD64"

$PROCESSOR_IDENTIFIER
[1] "Intel64 Family 6 Model 94 Stepping 3, GenuineIntel"

$PROCESSOR_LEVEL
[1] "6"

$PROCESSOR_REVISION
[1] "5e03"

$ProgramData
[1] "C:\\ProgramData"

$ProgramFiles
[1] "C:\\Program Files"

$`ProgramFiles(x86)`
[1] "C:\\Program Files (x86)"

$ProgramW6432
[1] "C:\\Program Files"

$PSModulePath
[1] "C:\\WINDOWS\\system32\\WindowsPowerShell\\v1.0\\Modules\\;C:\\Program Files\\Microsoft User Experience Virtualization\\Modules\\;C:\\Program Files\\Microsoft Application Virtualization\\Client\\"

$PUBLIC
[1] "C:\\Users\\Public"

$PYTHONPATH
[1] "M:\\pcraster-4.0.2_x86-64\\python"

$R_ARCH
[1] "/x64"

$R_COMPILED_BY
[1] "gcc 4.9.3"

$R_DOC_DIR
[1] "M:/R Statistics/R-3.5.1/doc"

$R_HOME
[1] "M:/R Statistics/R-3.5.1"

$R_LIBS_USER
[1] "//kclad.ds.kcl.ac.uk/anywhere/UserData/PSStore01/k1634825/My Documents/R/win-library/3.5"

$R_USER
[1] "//kclad.ds.kcl.ac.uk/anywhere/UserData/PSStore01/k1634825/My Documents"

$RMARKDOWN_MATHJAX_PATH
[1] "//kclad.ds.kcl.ac.uk/Appdata/StudentApps/RStudio/RStudio-1.1.456/resources/mathjax-26"

$RS_LOCAL_PEER
[1] "\\\\.\\pipe\\22972-rsession"

$RS_RPOSTBACK_PATH
[1] "//kclad.ds.kcl.ac.uk/Appdata/StudentApps/RStudio/RStudio-1.1.456/bin/rpostback"

$RS_SHARED_SECRET
[1] "63341846741"

$RSTUDIO
[1] "1"

$RSTUDIO_CONSOLE_COLOR
[1] "256"

$RSTUDIO_CONSOLE_WIDTH
[1] "80"

$RSTUDIO_MSYS_SSH
[1] "//kclad.ds.kcl.ac.uk/Appdata/StudentApps/RStudio/RStudio-1.1.456/bin/msys-ssh-1000-18"

$RSTUDIO_PANDOC
[1] "//kclad.ds.kcl.ac.uk/Appdata/StudentApps/RStudio/RStudio-1.1.456/bin/pandoc"

$RSTUDIO_SESSION_PORT
[1] "22972"

$RSTUDIO_USER_IDENTITY
[1] "k1634825"

$RSTUDIO_WINUTILS
[1] "//kclad.ds.kcl.ac.uk/Appdata/StudentApps/RStudio/RStudio-1.1.456/bin/winutils"

$SDS_ALGO_PATH
[1] "C:\\AppliedBiosystems\\SDS2.4\\lib\\algorithm\\bin\\win32;C:\\AppliedBiosystems\\SDS2.4\\lib"

$SESSIONNAME
[1] "Console"

$snow_agent
[1] "C:\\Program Files\\Snow Software\\Inventory\\Agent"

$SNOW_INVENTORY_HOME
[1] "C:\\Program Files\\INVENTORYCLIENT\\"

$SystemDrive
[1] "C:"

$SystemRoot
[1] "C:\\WINDOWS"

$TEMP
[1] "C:\\Users\\k1634825\\AppData\\Local\\Temp"

$TERM
[1] "xterm-256color"

$TMP
[1] "C:\\Users\\k1634825\\AppData\\Local\\Temp"

$UATDATA
[1] "C:\\WINDOWS\\CCM\\UATData\\D9F8C395-CAB8-491d-B8AC-179A1FE1BE77"

$USERDNSDOMAIN
[1] "KCLAD.DS.KCL.AC.UK"

$USERDOMAIN
[1] "KCLAD"

$USERDOMAIN_ROAMINGPROFILE
[1] "KCLAD"

$USERNAME
[1] "k1634825"

$USERPROFILE
[1] "C:\\Users\\k1634825"

$windir
[1] "C:\\WINDOWS"

 [1] ".GlobalEnv"        "tools:rstudio"     "package:stats"     "package:graphics"  "package:grDevices"
 [6] "package:utils"     "package:datasets"  "package:methods"   "Autoloads"         "package:base"     
Log file: rdesktop.log
--------------------------------------------------

(Empty)

Log file: rsession-k1634825.log
--------------------------------------------------

03 Jan 2019 18:03:17 [rsession-k1634825] CLIENT EXCEPTION (rsession-k1634825): (TypeError) : undefined is not an object (evaluating 'this.a.a.r.row');|||com/google/gwt/dev/jjs/intrinsic/com/google/gwt/lang/Exceptions.java#28::wrap|||com/google/gwt/core/client/impl/SchedulerImpl.java#167::runScheduledTasks|||com/google/gwt/core/client/impl/SchedulerImpl.java#338::flushPostEventPumpCommands|||com/google/gwt/core/client/impl/SchedulerImpl.java#76::execute|||com/google/gwt/core/client/impl/SchedulerImpl.java#140::execute|||com/google/gwt/core/client/impl/Impl.java#244::apply|||com/google/gwt/core/client/impl/Impl.java#283::entry0|||#-1::anonymous|||com/google/gwt/cell/client/AbstractEditableCell.java#41::viewDataMap|||Client-ID: 33e600bb-c1b1-46bf-b562-ab5cba070b0e|||User-Agent: Mozilla/5.0 (Windows NT 6.2  WOW64) AppleWebKit/538.1 (KHTML, like Gecko) rstudio Safari/538.1 Qt/5.4.1

From RStudio Desktop Will Not Start on support.rstudio.com


#2

Folks on my team, including myself, have seen intermittent Rstudio slowness as you've described. In our case, the issue seems to be that the $HOME environment variable pointing to a network drive. At some point our corporate IT changed everyone's default home directory to be on the network instead of a local folder. Our current work around is to login to our pc's without being connected to the corporate network (which involves booting up with WiFi turned off when we're in the office). This causes the pc to set the $HOME directory back to a folder under C:\Users\ which seems to solve the problem.

May not be your issue, but since I noticed your $HOME variable is on a network drive I thought I'd mention it.


#3

Thanks, that seems to have sorted it. IT started by re-imaging my desktop which improved things a little but did mean I had to spend rather a lot of time re-installing everything. After I demonstrated that it was still slow they agreed to set it to a local drive.