Facing trouble while Package Installation (“tidyverse” package)

I’m working on a course for that I need to install tidyverse package, while installing tidyverse I’m facing an error.

Please help, I need urgent help.


Welcome to the RStudio community!

Can you try and run it without the dependencies = TRUE. Also make sure you have internet connection and your system is not blocking installs (if you are at a work place, often installing of R packages is limited to admins only).

Hope this helps,

1 Like

Can you get to https://cran.rstudio.com/src/contrib/PACKAGES using your normal browser? If not, some permissions on your network may be blocking the installation, a situation similar to what was suggested by @pieterjanvc .


Sir, I had tried without dependencies too and also checked my net connection. But, the problem is not solved yet.
Thank You

Sir, I can access this link from my browser.

And, I also checked my net connection, but this error comes again and again.
Thank You

1 Like

This seems like a connectivity issue, R is not being able to connect to the CRAN repository you have selected, these are some things to try.

  • Choose a different CRAN repository, RStudios repository is a good choice (http://cran.rstudio.com/) or you could choose one that is geographically closer to you.
  • Disable secure download setting.
  • Check if your internet connection has traffic restrictions of some kind, like a firewall, proxy server, etc. This is usually the case when you are at work or school.

It worked,
Thank you :pray:t2:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.