Fail to fetch data from worldbank using the WDI package


Return: None of the indicators your requested could be downloaded. Please verify the arguments of the WDI() function. You can also type a URL of this form in your browser to check if the World Bank web API is currently serving the indicator(s) of interest:

I think I could not access to world bank database using R for some reasons. Any suggestion?

I have never used WDI before but a test run with your code worked for me.

Is there any chance you are behind some kind of firewall?

BTW I am running Ubuntu 20.04, what is your OS? I keep hearing all sorts of weird things about Windows 10 permissions.

1 Like

Actually I tested it again last night and it worked. Something wrong with my internet connection at that time I guess. Thanks for answering.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.