Failed to connect to MySQL from Shiny Server but can connect via Rstudio Desktop

I'm successfully connecting to MySQL 8 on Managed DigitalOcean DB on both Mac OS and Linux 18.04. On a DigitalOcean Ubuntu 18.04 droplet I can also connect to same DB via MySQL shell. However, when a shiny app tries to connect it fails. Trying to connect via R > results in the following error:

Error: Failed to connect: Authentication plugin 'caching_sha2_password' cannot be loaded: /usr/lib/x86_64-linux-gnu/mariadb18/plugin/ cannot open shared object file: No such file or directory

Connecting via group:

con <- dbConnect(RMariaDB::MariaDB(), group = "xyz")

With xyz defined on ~/.my.cnf
I defined this the exact same way on the linux server and on the mac.
Also tried to login from R> with hardcoded credentials, but get same error.
I did install Connector/C on Ubuntu server:

sudo apt-get install -y libmariadbclient-dev

And have also tried MyQL client library:

sudo apt-get install -y libmysqlclient-dev

Always get the same error as a result.

Any hints as to what might be the issue?

This topic was automatically closed 54 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.