failed to run csv file in pa package

I loaded a package called "pa" in R trying to do some basic performance attribution analysis for my portfolio, the pa package comes with its own data frame, namely "year"

I tried the data (year) in the console line, it works

My problem.....

I tried to create/import a CSV file via Rstudio and I call it Rtestcsv (with all my holding and Bloomberg code)

I tried to type [data (Rtestcsv)] in the console, error msg pops up and said the file is not found, why?

is it true the "pa" package created by Yang Lu can only apply to his own data frame?

In order to use the "pa" package performance simple analysis, what should i have to do with my own data frame? coz it seems the CSV file has been successfully imported and appeared in the top right-hand R environment

I would appreciate if someone could shed me some insights to handle my issue as I am new to R


1 Like

Your object is available in memory as soon as you have imported it in R.
I see that you already have Rtestcsv in your workspace. Just type

> Rtestcsv

in the console to call it. without data(), which is a function to call built-in dataset.

As you are a beginner I would advice to follow an intro to R course as this is the basics. You have several options:

1 Like

thank you so much Christophe, i will def take your advice to have some course first ><



This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.