failure to load "tidyverse"

I have trouble loading "library(tidyverse)" today with the following error message:

"Error: package or namespace load failed for ‘tidyverse’ in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
namespace ‘vctrs’ 0.2.4 is being loaded, but >= 0.3.2 is required"

I've tried a few troubleshoots, including updating packages, upgrading Studio to 1.3.1093, install.packages("tidyverse", dependencies = TRUE), install.packages("scales"), but still getting the same error message.

The Rstudio worked just fine yesterday. In fact, I have never encountered a similar problem before.

Would greatly appreciate any ideas on how to fix it.

Thanks,
Judy

Hi Judy,
The original error message includes

 ‘vctrs’ 0.2.4 is being loaded, but >= 0.3.2 is required"

This means that installing a more up to date version is the way to go, before going back and trying to load tidyverse again.

install.packages("vctrs")

alternatively if you install renv package like

install.packages("renv")

then you would be able to install a particular version of vctrs :

renv::install("vctrs@0.3.2")

Thank you for your response.

I was able to install "renv", but got the following error messages when I tried "renv::install("vctrs@0.3.2")":

xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun
ERROR: compilation failed for package ‘vctrs’

I searched prior post for the similar settings. It sounds like the error maybe due to mac system and one suggestion was to install Xcode.

Should I install Xcode? My other question is why I have not encountered the same problem over the past six months when I used Rstudio?

Thanks!
Judy

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.