Fatal R Session Error when navigating "Files" pane

Howdy y'all,

I've suddenly started experiencing a pop-up error window saying the current R session was aborted due to a fatal error, then it exits and restarts the session. It is occurring when I'm just navigating through the "Files" pane. Here is the error message from the log. I bolded two particular things because I noticed the only thing that changes in the error logs is based on what I have open in the "Help" pane at the time:

10 Sep 2020 16:17:29 [rsession-mmiller] ERROR system error 10053 (An established connection was aborted by the software in your host machine) [request-uri: /help/library/base/html/DateTimeClasses.html]; OCCURRED AT void __cdecl rstudio::session::HttpConnectionImpl::sendResponse(const class rstudio::core::http::Response &) src/cpp/session/http/SessionWin32HttpConnectionListener.cpp:113; LOGGED FROM: void __cdecl rstudio::session::HttpConnectionImpl::sendResponse(const class rstudio::core::http::Response &) src/cpp/session/http/SessionWin32HttpConnectionListener.cpp:118

10 Sep 2020 16:17:44 [rsession-mmiller] ERROR system error 10053 (An established connection was aborted by the software in your host machine) [request-uri: /help/library/graphics/html/plot.default.html]; OCCURRED AT void __cdecl rstudio::session::HttpConnectionImpl::sendResponse(const class rstudio::core::http::Response &) src/cpp/session/http/SessionWin32HttpConnectionListener.cpp:113; LOGGED FROM: void __cdecl rstudio::session::HttpConnectionImpl::sendResponse(const class rstudio::core::http::Response &) src/cpp/session/http/SessionWin32HttpConnectionListener.cpp:118

The only other case of this specific issue I've found is somewhat recent and looks to be unresolved. I've allowed RStudio through Windows Defender for network, public, and private connections. I've uninstalled R and installed the most recent version, uninstalled and installed the most recent RStudio. This did start occurring shortly after installing Git so that I could add a repo as a project. I uninstalled Git before doing the fresh R/Rstudio install and did not reinstall it but it's still happening. Any ideas on next steps? Many thanks in advance.

Most of the diagnostics log incase it could be useful:

RStudio Version
--------------------------------------------------
1.3.1073


Session Information
--------------------------------------------------
R version 4.0.2 (2020-06-22)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows 10 x64 (build 18363)

Matrix products: default

locale:
[1] LC_COLLATE=English_United States.1252  LC_CTYPE=English_United States.1252   
[3] LC_MONETARY=English_United States.1252 LC_NUMERIC=C                          
[5] LC_TIME=English_United States.1252    

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

loaded via a namespace (and not attached):
[1] compiler_4.0.2 tools_4.0.2    tinytex_0.25   xfun_0.16     


System Information
--------------------------------------------------
sysname        : Windows        
release        : 10 x64         
version        : build 18363    
nodename       : LOANERDSF-04204
machine        : x86-64         
login          : mmiller        
user           : mmiller        
effective_user : mmiller        


Platform Information
--------------------------------------------------
OS.type    : windows
file.sep   : /
dynlib.ext : .dll
GUI        : RStudio
endian     : little
pkgType    : win.binary
path.sep   : ;
r_arch     : x64


Environment Variables
--------------------------------------------------
ALLUSERSPROFILE                 : C:\ProgramData
APPDATA                         : C:\Users\mmiller\AppData\Roaming
ChocolateyInstall               : C:\ProgramData\chocolatey
CLICOLOR_FORCE                  : 1
CommonProgramFiles              : C:\Program Files\Common Files
CommonProgramFiles(x86)         : C:\Program Files (x86)\Common Files
CommonProgramW6432              : C:\Program Files\Common Files
COMPUTERNAME                    : LOANERDSF-04204
ComSpec                         : C:\WINDOWS\system32\cmd.exe
DISPLAY                         : :0
DriverData                      : C:\Windows\System32\Drivers\DriverData
ESET_OPTIONS                    :                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                
FPS_BROWSER_APP_PROFILE_STRING  : Internet Explorer
FPS_BROWSER_USER_PROFILE_STRING : Default
GFORTRAN_STDERR_UNIT            : -1
GFORTRAN_STDOUT_UNIT            : -1
HOME                            : C:\Users\mmiller\Documents
HOMEDRIVE                       : C:
HOMEPATH                        : \Users\mmiller
LOCALAPPDATA                    : C:\Users\mmiller\AppData\Local
LOGONSERVER                     : \\DEN-DC-1
MPLENGINE                       : tkAgg
MSYS2_ENV_CONV_EXCL             : R_ARCH
NIEXTCCOMPILERSUPP              : C:\Program Files (x86)\National Instruments\Shared\ExternalCompilerSupport\C\
NUMBER_OF_PROCESSORS            : 4
OneDrive                        : C:\Users\mmiller\OneDrive
OS                              : Windows_NT
PATH                            : C:\Users\mmiller\Documents\R\R-4.0.2\bin\x64;C:\Program Files (x86)\Common Files\Oracle\Java\javapath;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0\;C:\WINDOWS\System32\OpenSSH\;C:\Program Files (x86)\Webex\Webex\Applications;C:\ProgramData\chocolatey\bin;C:\Program Files (x86)\IVI Foundation\VISA\WinNT\Bin\;C:\Program Files\IVI Foundation\VISA\Win64\Bin\;C:\Program Files (x86)\IVI Foundation\VISA\WinNT\Bin;C:\Program Files (x86)\PuTTY\;C:\usr\bin;C:\Program Files\Intel\WiFi\bin\;C:\Program Files\Common Files\Intel\WirelessCommon\;C:\Program Files (x86)\Microsoft SQL Server\Client SDK\ODBC\110\Tools\Binn\;C:\Program Files (x86)\Microsoft SQL Server\120\Tools\Binn\;C:\Program Files (x86)\Microsoft SQL Server\120\DTS\Binn\;C:\Users\mmiller\AppData\Local\Microsoft\WindowsApps;C:\Users\mmiller\AppData\Local\GitHubDesktop\bin;C:\Users\mmiller\AppData\Local\Programs\Microsoft VS Code\bin;C:\Users\mmiller\AppData\Local\Programs\Git\cmd
PATHEXT                         : .COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC
PROCESSOR_ARCHITECTURE          : AMD64
PROCESSOR_IDENTIFIER            : Intel64 Family 6 Model 61 Stepping 4, GenuineIntel
PROCESSOR_LEVEL                 : 6
PROCESSOR_REVISION              : 3d04
ProgramData                     : C:\ProgramData
ProgramFiles                    : C:\Program Files
ProgramFiles(x86)               : C:\Program Files (x86)
ProgramW6432                    : C:\Program Files
PSModulePath                    : C:\Program Files\WindowsPowerShell\Modules;C:\WINDOWS\system32\WindowsPowerShell\v1.0\Modules;C:\Program Files (x86)\Microsoft SQL Server\120\Tools\PowerShell\Modules\
PUBLIC                          : C:\Users\Public
QT_D3DCREATE_MULTITHREADED      : 1
R_ARCH                          : /x64
R_COMPILED_BY                   : gcc 8.3.0
R_DOC_DIR                       : C:/Users/mmiller/DOCUME~1/R/R-40~1.2/doc
R_HOME                          : C:/Users/mmiller/DOCUME~1/R/R-40~1.2
R_LIBS_USER                     : C:/Users/mmiller/Documents/R/win-library/4.0
R_USER                          : C:/Users/mmiller/Documents
RMARKDOWN_MATHJAX_PATH          : C:/Program Files/RStudio/resources/mathjax-27
RS_LOCAL_PEER                   : \\.\pipe\22528-rsession
RS_RPOSTBACK_PATH               : C:/Program Files/RStudio/bin/rpostback
RS_SHARED_SECRET                : *** redacted ***
RSTUDIO                         : 1
RSTUDIO_CONSOLE_COLOR           : 256
RSTUDIO_CONSOLE_WIDTH           : 80
RSTUDIO_MSYS_SSH                : C:/Program Files/RStudio/bin/msys-ssh-1000-18
RSTUDIO_PANDOC                  : C:/Program Files/RStudio/bin/pandoc
RSTUDIO_PROGRAM_MODE            : desktop
RSTUDIO_SESSION_PORT            : 22528
RSTUDIO_USER_IDENTITY           : mmiller
RSTUDIO_WINUTILS                : C:/Program Files/RStudio/bin/winutils
SESSIONNAME                     : Console
SystemDrive                     : C:
SystemRoot                      : C:\WINDOWS
TEMP                            : C:\Users\mmiller\AppData\Local\Temp
TERM                            : xterm-256color
TMP                             : C:\Users\mmiller\AppData\Local\Temp
UATDATA                         : C:\windows\CCM\UATData\D9F8C395-CAB8-491d-B8AC-179A1FE1BE77
USERDNSDOMAIN                   : **redacted**
USERDOMAIN                      : ECO
USERDOMAIN_ROAMINGPROFILE       : ECO
USERNAME                        : *** redacted ***
USERPROFILE                     : C:\Users\mmiller
VXIPNPPATH                      : C:\Program Files (x86)\IVI Foundation\VISA\
VXIPNPPATH64                    : C:\Program Files\IVI Foundation\VISA\
windir                          : C:\WINDOWS


R Version
--------------------------------------------------
platform       : x86_64-w64-mingw32
arch           : x86_64
os             : mingw32
system         : x86_64, mingw32
status         : 
major          : 4
minor          : 0.2
year           : 2020
month          : 06
day            : 22
svn rev        : 78730
language       : R
version.string : R version 4.0.2 (2020-06-22)
nickname       : Taking Off Again


R Home
--------------------------------------------------
C:/Users/mmiller/DOCUME~1/R/R-40~1.2


R Search Path
--------------------------------------------------
.GlobalEnv       
tools:rstudio    
package:stats    
package:graphics 
package:grDevices
package:utils    
package:datasets 
package:methods  
Autoloads        
package:base     


R Library Paths
--------------------------------------------------
C:/Users/mmiller/Documents/R/R-4.0.2/library

EDIT: Now the error log has a different request-uri so maybe not so important. Everything else was the same but:

[request-uri: /events/get_events]

1 Like

I resolved this issue by installing the preview version of RStudio: RStudio Preview - RStudio

2 Likes

Thank you! I had this problem and your solution fixed my issue as well.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.