Fedora RPM RStudio broken under Gnome/Xorg

The published RPM (https://download1.rstudio.org/desktop/centos8/x86_64/rstudio-1.3.959-x86_64.rpm) works under Gnome/Wayland on Fedora 31/32, but freezes non-reproducibly when Gnome is set to use Xorg not Wayland. Why does this matter? Because Teams does not (yet) permit screen sharing under Wayland, but does under Xorg. However, since the RStudio IDE freezes under Gnome/Xorg (set the Fedora login to Xorg rather than Wayland - https://docs.fedoraproject.org/en-US/quick-docs/configuring-xorg-as-default-gnome-session/) unpredictably, it cannot be used for screen sharing through Teams. I'd be grateful for tips other than switching to Windows 10 after duplicating my whole teaching environment there.

1 Like

Re-checking with the crash-handler on, the entries are empty, with:

$ od -b ~/.r/crashpad_database/settings.dat
0000000 163 144 120 103 001 000 000 000 001 000 000 000 000 000 000 000
0000020 000 000 000 000 000 000 000 000 322 326 133 036 153 121 272 113
0000040 207 220 222 164 031 027 372 014
0000050

Typically, the whole RStudio window goes blank apart from the top menu line, is unresponsive, and has to be killed, for example from the system monitor. To check the running session interface, use e.g.:

loginctl show-session 2 -p Type

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

Unfortunately, Gnome/Wayland is also, but less, unstable under F32. Much more effort is required to provide RPMs that work.

Raised as https://github.com/rstudio/rstudio/issues/7217

Reports on the github issue indicate that installing the preview version from RStudio Preview - RStudio helps, and that the underlying cause may be a QT issue exposed by newer glibc - see the issue https://github.com/rstudio/rstudio/issues/7217 for details.