figure in documentation not showing.

I am trying to include a picture in the documentation of a package. I think my code is correct and the file is placed correctly, but the picture is not being shown in the documentation.

Roxygen code:

#' @section Figures:
#' \if{html}{\figure{eq_FPKA.PNG}{options: width=100\%}}

The file exists and is placed in 'man/figures':

> file.exists(here("man", "figures", "eq_FPKA.PNG"))
[1] TRUE

But when I run document() and inspect the documentation of the file it just looks like this:

The image is not displayed.
I have tried inserting a path to a file that doesn't exist. The result looks the same.
I have also tried to run install(), restart R and run the documentation on the installed package. The result is the same.

I have also tried renaming the file from 'eq_FPKA.PNG' to 'eqFPKA.PNG' to avoid the underscore, but again... no difference.

Can anybody give me some ideas as to what is going on?

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.