Full_join –> Error: Object not found

Hi, I am a beginner with R. I have a basic problem: "object not found". I worked in R a few days ago and I saved my work. I would like to continue mutating all the tables into one. I tried to mutate dataset "DM" with "full_df", but R found the error "object not found" even though that is in R (the error occurs for every inserted dataset). Specifically I am using: "full_df1 <- full_join(DM, full_df)". Could you please tell where could be the problem?
Thank you!

Those data frames/objects are appearing in RStudio from previous sessions (If you go to RStudio > Preferences > General, you'll see there's a radio button for Restore previously open source documents at startup, which is why you're seeing them in your "new" session). The objects aren't actually in your active R session. However you read them in the first time around you need to do in the active R session in order to manipulate work with them.

2 Likes

Hi, thank you so much for your help! I was fighting with that for almost half of the day.
Have a nice day:)