ggplot2 could not be installed in my Rstudio

I have tried several times to install ggplot2, but I keep getting the following error message:

URL '': Timeout of 60 seconds was reached
*Error in download.file(url, destfile, method, mode = "wb", ...) : *

Please, kindly help me fix this problem.

This seems like a connectivity issue, R is not being able to connect to the CRAN repository you have selected, these are some things to try.

  • Choose a different CRAN repository, RStudios repository is a good choice ( or you could choose one that is geographically closer to you.
  • Disable secure download setting.
  • Check if your internet connection has traffic restrictions of some kind, like a firewall, proxy server, etc. This is usually the case when you are at work or school.
1 Like

Thanks . It was definitely network.. It got fixed.

Kindly help me with this new problem:

I encounter this error message each time I tried to knit my Rmarkdown note book.

It also says my data frame could not be gotten........

We like to keep things tidy around here so please ask only one question per topic, if you have distinct questions you can always open a new topic.

I'm going to shortly adress your other questions. You should not include install commands in a Rmd file because you only need to install packages once, not every time you knit a document, you only need to load the packages with library().
About the missing data frame, when you knit a Rmd document the code gets executed in a clean environment other than the one you are currently working on so you have to include the necessary code to read the data frame into memory.

If you need further assistance with any of this, please open a new specific topic for it.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.