"Git" tab suddenly disappeared, how to put it back?

The Git tab in RStudio (next to "Environment", "History", etc.) suddenly disappeared. I don't know what did this, and I can't figure out how to put it back. Restarting RStudio doesn't change anything.

Moreover, this mistake made Git unavailable when using the IDE, e.g creating a project with ticking "Create a git repository" generates an error: "Incorrect function". This is strange because in global options, I can still see the path to the Git executable. In project options, the version control system is automatically put on "None" and if I change it to "Git", the same error "Incorrect function" appears.

Using usethis::use_git() and usethis::use_github() to initiate git work, but the Git pane still doesn't appear in RStudio.

What should I do?

Edit: following this answer, I tried to reset RStudio's state by renaming the "RStudio" folder as "RStudio-backup" and restarting RStudio. This didn't work, the "Git" pane is still not displayed.

So you say that you can't create a new project with version control?
Could it be that the Git program (git.exe in my case) was removed?
Does it help when you reinstall that?

Creating a new project and ticking the box "Create a git repository" creates a project but there is an error and git is not initialized. However, once the project is created, usethis::use_git() works. Reinstalling git doesn't make Rstudio detect it.

Note that this happens on a server at work, so I don't have the rights to reinstall rstudio.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.