GLMER.NB, Tol not found

Hi all,

I'm doing a multilevel negative binomial regression analysis, using the LME4 package.
I created the following script:

R< nb <- glmer.nb(MOP ~ age+experience+(1|SubjectID), data = Data, interval = log(th) + c(-3, 3), tol = 5e-5, verbose = FALSE, nb.control = NULL, initCtrl = list(limit = 20, eps = 2*tol, trace = verbose, theta = NULL))

When I run this code, it gives me the following outcome:
object 'tol' not found

I tried to install packages MASS and Optimize, however R says these packages aren't available for R version 3.4.3.

Is there anyone who worked with this analysis and can help me with this?

Thank you in advance!

you are using tol (you multiply it by 2 and pass it to eps) without having defined it.
something like

 tol <- 5e-5

would likely work

you can get documentation on your function call with the questionmark symbol in your console

?glmer.nb

it shows that it should be a logical, so FALSE or TRUE, or leave it blank ( i.e. dont mention the param at all) and the default would be false

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

It worked indeed! Thank you :slight_smile:

Now it says: object 'verbose' not found
Should I also define this one, and if so; how?