glmgen error during the publish

Hello
We are able to install the package glmgen successfullly. However, we get the following error when we try to publish. Would appreciate any help we can get to resolve.

[Connect] 2020/06/19 16:12:33.516443645 Additional data:
[Connect] RequiredFile: 'libopenblasp.so.0'
[Connect] Package: 'glmgen'
[Connect] PackageVersion: '0.0.3.0.0.0.1590969407'
[Connect] Found in the following log entry:
[Connect] ackrat/3.6.3/v2/library/Matrix/54974505e2addac3ec63f9d4bf8ff98a/Matrix/libs/Matrix.so':\n libopenblasp.so.0: cannot open shared object file: No such file or directory\nCalls: ... asNamespace -> loadNamespace -> library.dynam -> dyn.load\nExecution halted\nERROR: lazy loading failed for package ‘glmgen’\n* removing ‘/opt/rstudio-connect/mnt/app/packrat/lib/x86_64-pc-linux-gnu/3.6.3/glmgen’"

[Connect] Build error: An R package cannot be installed because a required system-level dependency is missing. (r-missing-system-library)
Application deployment failed with error: An R package cannot be installed because a required system-level dependency is missing. (r-missing-system-library)
Warning messages:
1: invalid uid value replaced by that for user 'nobody'
2: invalid gid value replaced by that for user 'nobody'

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.