Grey screen on shiny with R Studio Server

connection

#1

Hello! I get a grey screen when using Shiny with my R Studio Server. I tried to downgrade shiny and httpuv, I updated R Studio to Version 1.1.453, and I tried different web browser and different hardware, but still got the problem.

This is my sessionInfo():

R version 3.5.0 (2018-04-23)
Platform: x86_64-pc-linux-gnu (64-bit)
Running under: Debian GNU/Linux 9 (stretch)

Matrix products: default
BLAS: /usr/lib/atlas-base/atlas/libblas.so.3.0
LAPACK: /usr/lib/atlas-base/atlas/liblapack.so.3.0

locale:
 [1] LC_CTYPE=en_US.UTF-8       LC_NUMERIC=C               LC_TIME=en_US.UTF-8       
 [4] LC_COLLATE=en_US.UTF-8     LC_MONETARY=en_US.UTF-8    LC_MESSAGES=en_US.UTF-8   
 [7] LC_PAPER=en_US.UTF-8       LC_NAME=C                  LC_ADDRESS=C              
[10] LC_TELEPHONE=C             LC_MEASUREMENT=en_US.UTF-8 LC_IDENTIFICATION=C       

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

other attached packages:
[1] ggvis_0.4.3 shiny_1.1.0

loaded via a namespace (and not attached):
 [1] Rcpp_0.12.16      digest_0.6.15     dplyr_0.7.5       later_0.7.3       assertthat_0.2.0 
 [6] mime_0.5          R6_2.2.2          xtable_1.8-2      magrittr_1.5      pillar_1.2.3     
[11] rlang_0.2.1       promises_1.0.1    bindrcpp_0.2.2    tools_3.5.0       glue_1.2.0       
[16] purrr_0.2.5       httpuv_1.4.3.9002 compiler_3.5.0    pkgconfig_2.0.1   htmltools_0.3.6

I appreciate your ideas!
Best wishes, Knilda


#2

I think I'm seeing the same issue, same version of R and RStudio Server running on RedHat 7. And the issue persists after publishing the app to RStudio Connect (w/ same version of R).