How to change RStudio display language into English

I use the latest version of Rstudio Version 1.2.5019, but it start with Chinese

I have changed Rconsole file's Language for messages item into En both in my Document folder and the R path \etc folder. The Default R shows english

But Rstudio still show Chinese there.

Could you execute this in the RStudio console:

It is getting details of aspects of the locale for this R process which is running inside your RStudio.
Do you have more than one R instances locally installed?

RStudio does not read this file during launch. You can see how R's own GUI uses this file during launch:

In theory, ensuring that the LANGUAGE=en environment variable is set should ensure R uses English messages for output, but I have not been able to verify that this is the case.

I execute this in Rstudio console

It shows like that

[1] "LC_COLLATE=Chinese (Simplified)_China.936;LC_CTYPE=Chinese (Simplified)_China.936;LC_MONETARY=Chinese (Simplified)_China.936;LC_NUMERIC=C;LC_TIME=Chinese (Simplified)_China.936"

It seems that it is Chinese, so how to change that into something like utf-8 ?

Cool - that probably means you're on the right way to answer the question.
3 additional questions:

  1. Which OS are you using at your computer?
  2. Which locale is set on your computer?
  3. Do you want to keep the chinese values for Sys.getlocale() and only modify the charset to utf-8?

I use windows 10
My locale set on my computer is Chinese
I think may be modify the charset to utf-8 is better
So how can I change this setting into utf-8 ?

That probably explains why RStudio is using simplified chines signs: It takes the settings of your OS (and this is simplified chinese).
Sys.getenv() gives you a list of all the environment variables that are set,
Sys.setenv sets environment variables

Please have a look into the following helpful pages:

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.