How to fix Rstudio can not read Thai language data

rstudio

#1

Hi everyone,

I have an issue related to ‘Thai language data’ which is the same as this topic Here

Please advise.

Thank you so much.
K


#2

Based on the image in the support post, you likely need to set the Encoding field to match the encoding of the actual document (perhaps it is UTF-8?) Unfortunately, without prior information it’s hard to know what the encoding might be without just testing a bunch of different ones to see what ‘looks right’.

Can you elaborate on the second question in your post (sentences not being shown)?


#3

Hi kevinushey,
Thanks for support. Please allow me to give us the exact step of reproduce as below:

Step of reproduce:
1.Start RStudio Version 1.1.383
2.library(Rcmdr)
3.Use R Commander then select Data -> Import Data -> from Excel file…
4.Select the file (Open file) - at this moment, the Rstudio will display RcmdrMsg: [2] NOTE: The dataset Dataset has 1419 rows and 10 columns.
5.Then back to the R Commander select Statistics -> Summaries -> Active data set
*6. Rstudio will display alienate language as example below:

See Data set “here”

By the way, I have tried by setting Encoding to be UTF-8 in global setting but the issue still persists.

Regards,
K


#4

Sorry, but as this example is not reproducible there’s not much I can do to help further. (I don’t have access to the dataset you’re attempting to read)

Based on the output, it looks like the read attempt is failing because whichever API Rcmdr is using to read the file are not providing the associated file encoding. (The names e.g. <U+0E2A> are unicode code points; R generally converts characters to those when an attempt to translate UTF-8 text to the system encoding would fail)