How to prevent flextable from splitting from page break

I need to print flextable output in a Rmarkdown file knitting to .docx format. Even if I include the chunk option 'ft.keepnext=T' the table is still split.

I could manually add a pagebreak before the code chunk, but I'd rather do this programmatically.