How to turn off tab code completion

I want to turn off code completion. In particular, I want to turn off the key binding that makes "tab" trigger autocomplete.

I have already unchecked the box for "Allow automatic completion in console", and this didn't resolve the problem.

My reproducible example isn't very interesting: I enter the letter s, click tab, and R Studio suggests "surv". I want tab to insert spaces.

Note: Per an R Studio Community post from 2017, this apparently couldn't be done outside a custom build of R Studio (Keyboard shortcuts). Is this still the case?

RStudio: 1.2.5033-1
R: 3.6.2
Mac OS: 10.14.3

It's now possible to disable the Tab key used for autocompletion in the v1.3 preview release:

See the option [x] Use tab for autocompletions.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.