How to turn off undesirable_function_linter in .lintr ?

With the latest version of lintr, I am getting some fails which I have not had before. While I figure out the best way to handle this, I would like to turn off a couple of checks. I have successfully turned off indentation checks with indentation_linter=NULL in the .lintr file. I would like to do the same with undesirable_function_linter, but am getting configuration errors. Can someone give me an example of how to turn off undesirable_function_linter? Thanks.

Ack! My .lintr file was ADDING undesirable_function_linter:

linters: linters_with_defaults(
    line_length_linter(100),
    object_usage_linter=NULL,
    cyclocomp_linter(complexity_limit = 22),
    undesirable_function_linter = undesirable_function_linter()
  )

I just needed to remove that line!

3 Likes

Glad you fixed it! Could you please mark your response as the solution so that others know this thread has been solved? FAQ: How do I mark a solution?