HTTP 599: Timeout during request

shinyappsio

#1

Dear all,

I am actually trying to upload my shiny application, and unfortunately every time I tried I got an Timeout error :

Preparing to deploy application...DONE
Uploading bundle for application: 499554...Detecting system locale ... DONE
Deploying bundle: 1629253 for application: 499554 ...
Waiting for task: 555410288
  building: Parsing manifest
  building: Building image: 1667032
  building: Installing system dependencies
  building: Fetching packages
  building: Building package: reactome.db
################################ Begin Task Log ################################ 
[2018-10-08T11:01:45.068103521+0000] Execute script: packages/build/rJava.sh
+ set -e
+ /usr/bin/R CMD javareconf
Java interpreter : /usr/bin/java
Java version     : 1.8.0_181
Java home path   : /usr/lib/jvm/java-8-openjdk-amd64/jre
Java compiler    : /usr/bin/javac
Java headers gen.: /usr/bin/javah
Java archive tool: /usr/bin/jar

trying to compile and link a JNI program 
detected JNI cpp flags    : -I$(JAVA_HOME)/../include -I$(JAVA_HOME)/../include/linux
detected JNI linker flags : -L$(JAVA_HOME)/lib/amd64/server -ljvm
gcc -I"/opt/R/3.5.1/lib/R/include" -DNDEBUG -I/usr/lib/jvm/java-8-openjdk-amd64/jre/../include -I/usr/lib/jvm/java-8-openjdk-amd64/jre/../include/linux  -I/usr/local/include   -fpic  -g -O2  -c conftest.c -o conftest.o
gcc -shared -L/opt/R/3.5.1/lib/R/lib -L/usr/local/lib -o conftest.so conftest.o -L/usr/lib/jvm/java-8-openjdk-amd64/jre/lib/amd64/server -ljvm -L/opt/R/3.5.1/lib/R/lib -lR


JAVA_HOME        : /usr/lib/jvm/java-8-openjdk-amd64/jre
Java library path: $(JAVA_HOME)/lib/amd64/server
JNI cpp flags    : -I$(JAVA_HOME)/../include -I$(JAVA_HOME)/../include/linux
JNI linker flags : -L$(JAVA_HOME)/lib/amd64/server -ljvm
Updating Java configuration in /opt/R/3.5.1/lib/R
Done.

[2018-10-08T11:01:46.035808202+0000] Execute script: packages/build/igraph.sh
+ set -e
+ apt-get update -qq
+ apt-get install -y libglpk-dev
Reading package lists...
Building dependency tree...
Reading state information...
The following additional packages will be installed:
  libamd2.4.1 libbtf1.2.1 libcamd2.4.1 libccolamd2.9.1 libcholmod3.0.6
  libcolamd2.9.1 libcsparse3.1.4 libcxsparse3.1.4 libglpk36 libgmp-dev
  libgmpxx4ldbl libklu1.3.3 libldl2.2.1 libspqr2.0.2 libsuitesparse-dev
  libsuitesparseconfig4.4.6 libumfpack5.7.1
Suggested packages:
  libiodbc2-dev gmp-doc libgmp10-doc libmpfr-dev
The following NEW packages will be installed:
  libamd2.4.1 libbtf1.2.1 libcamd2.4.1 libccolamd2.9.1 libcholmod3.0.6
  libcolamd2.9.1 libcsparse3.1.4 libcxsparse3.1.4 libglpk-dev libglpk36
  libgmp-dev libgmpxx4ldbl libklu1.3.3 libldl2.2.1 libspqr2.0.2
  libsuitesparse-dev libsuitesparseconfig4.4.6 libumfpack5.7.1
0 upgraded, 18 newly installed, 0 to remove and 25 not upgraded.
Need to get 2864 kB of archives.
After this operation, 12.2 MB of additional disk space will be used.
Get:1 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial/main amd64 libsuitesparseconfig4.4.6 amd64 1:4.4.6-1 [9322 B]
Get:2 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial/main amd64 libamd2.4.1 amd64 1:4.4.6-1 [21.3 kB]
Get:3 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial/main amd64 libbtf1.2.1 amd64 1:4.4.6-1 [10.8 kB]
Get:4 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial/main amd64 libcamd2.4.1 amd64 1:4.4.6-1 [20.0 kB]
Get:5 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial/main amd64 libccolamd2.9.1 amd64 1:4.4.6-1 [21.5 kB]
Get:6 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial/main amd64 libcolamd2.9.1 amd64 1:4.4.6-1 [15.7 kB]
Get:7 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial/main amd64 libcholmod3.0.6 amd64 1:4.4.6-1 [293 kB]
Get:8 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial/main amd64 libcsparse3.1.4 amd64 1:4.4.6-1 [26.3 kB]
Get:9 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial/main amd64 libcxsparse3.1.4 amd64 1:4.4.6-1 [62.8 kB]
Get:10 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial/universe amd64 libglpk36 amd64 4.57-1build3 [386 kB]
Get:11 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial/main amd64 libgmpxx4ldbl amd64 2:6.1.0+dfsg-2 [8948 B]
Get:12 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial/main amd64 libgmp-dev amd64 2:6.1.0+dfsg-2 [314 kB]
Get:13 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial/main amd64 libklu1.3.3 amd64 1:4.4.6-1 [71.5 kB]
Get:14 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial/main amd64 libldl2.2.1 amd64 1:4.4.6-1 [10.6 kB]
Get:15 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial/main amd64 libumfpack5.7.1 amd64 1:4.4.6-1 [223 kB]
Get:16 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial/main amd64 libspqr2.0.2 amd64 1:4.4.6-1 [63.6 kB]
Get:17 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial/main amd64 libsuitesparse-dev amd64 1:4.4.6-1 [899 kB]
Get:18 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial/universe amd64 libglpk-dev amd64 4.57-1build3 [408 kB]
debconf: delaying package configuration, since apt-utils is not installed
Fetched 2864 kB in 0s (26.2 MB/s)
Selecting previously unselected package libsuitesparseconfig4.4.6:amd64.
(Reading database ... 119114 files and directories currently installed.)
Preparing to unpack .../libsuitesparseconfig4.4.6_1%3a4.4.6-1_amd64.deb ...
Unpacking libsuitesparseconfig4.4.6:amd64 (1:4.4.6-1) ...
Selecting previously unselected package libamd2.4.1:amd64.
Preparing to unpack .../libamd2.4.1_1%3a4.4.6-1_amd64.deb ...
Unpacking libamd2.4.1:amd64 (1:4.4.6-1) ...
Selecting previously unselected package libbtf1.2.1:amd64.
Preparing to unpack .../libbtf1.2.1_1%3a4.4.6-1_amd64.deb ...
Unpacking libbtf1.2.1:amd64 (1:4.4.6-1) ...
Selecting previously unselected package libcamd2.4.1:amd64.
Preparing to unpack .../libcamd2.4.1_1%3a4.4.6-1_amd64.deb ...
Unpacking libcamd2.4.1:amd64 (1:4.4.6-1) ...
Selecting previously unselected package libccolamd2.9.1:amd64.
Preparing to unpack .../libccolamd2.9.1_1%3a4.4.6-1_amd64.deb ...
Unpacking libccolamd2.9.1:amd64 (1:4.4.6-1) ...
Selecting previously unselected package libcolamd2.9.1:amd64.
Preparing to unpack .../libcolamd2.9.1_1%3a4.4.6-1_amd64.deb ...
Unpacking libcolamd2.9.1:amd64 (1:4.4.6-1) ...
Selecting previously unselected package libcholmod3.0.6:amd64.
Preparing to unpack .../libcholmod3.0.6_1%3a4.4.6-1_amd64.deb ...
Unpacking libcholmod3.0.6:amd64 (1:4.4.6-1) ...
Selecting previously unselected package libcsparse3.1.4:amd64.
Preparing to unpack .../libcsparse3.1.4_1%3a4.4.6-1_amd64.deb ...
Unpacking libcsparse3.1.4:amd64 (1:4.4.6-1) ...
Selecting previously unselected package libcxsparse3.1.4:amd64.
Preparing to unpack .../libcxsparse3.1.4_1%3a4.4.6-1_amd64.deb ...
Unpacking libcxsparse3.1.4:amd64 (1:4.4.6-1) ...
Selecting previously unselected package libglpk36:amd64.
Preparing to unpack .../libglpk36_4.57-1build3_amd64.deb ...
Unpacking libglpk36:amd64 (4.57-1build3) ...
Selecting previously unselected package libgmpxx4ldbl:amd64.
Preparing to unpack .../libgmpxx4ldbl_2%3a6.1.0+dfsg-2_amd64.deb ...
Unpacking libgmpxx4ldbl:amd64 (2:6.1.0+dfsg-2) ...
Selecting previously unselected package libgmp-dev:amd64.
Preparing to unpack .../libgmp-dev_2%3a6.1.0+dfsg-2_amd64.deb ...
Unpacking libgmp-dev:amd64 (2:6.1.0+dfsg-2) ...
Selecting previously unselected package libklu1.3.3:amd64.
Preparing to unpack .../libklu1.3.3_1%3a4.4.6-1_amd64.deb ...
Unpacking libklu1.3.3:amd64 (1:4.4.6-1) ...
Selecting previously unselected package libldl2.2.1:amd64.
Preparing to unpack .../libldl2.2.1_1%3a4.4.6-1_amd64.deb ...
Unpacking libldl2.2.1:amd64 (1:4.4.6-1) ...
Selecting previously unselected package libumfpack5.7.1:amd64.
Preparing to unpack .../libumfpack5.7.1_1%3a4.4.6-1_amd64.deb ...
Unpacking libumfpack5.7.1:amd64 (1:4.4.6-1) ...
Selecting previously unselected package libspqr2.0.2:amd64.
Preparing to unpack .../libspqr2.0.2_1%3a4.4.6-1_amd64.deb ...
Unpacking libspqr2.0.2:amd64 (1:4.4.6-1) ...
Selecting previously unselected package libsuitesparse-dev:amd64.
Preparing to unpack .../libsuitesparse-dev_1%3a4.4.6-1_amd64.deb ...
Unpacking libsuitesparse-dev:amd64 (1:4.4.6-1) ...
Selecting previously unselected package libglpk-dev.
Preparing to unpack .../libglpk-dev_4.57-1build3_amd64.deb ...
Unpacking libglpk-dev (4.57-1build3) ...
Processing triggers for libc-bin (2.23-0ubuntu10) ...
Setting up libsuitesparseconfig4.4.6:amd64 (1:4.4.6-1) ...
Setting up libamd2.4.1:amd64 (1:4.4.6-1) ...
Setting up libbtf1.2.1:amd64 (1:4.4.6-1) ...
Setting up libcamd2.4.1:amd64 (1:4.4.6-1) ...
Setting up libccolamd2.9.1:amd64 (1:4.4.6-1) ...
Setting up libcolamd2.9.1:amd64 (1:4.4.6-1) ...
Setting up libcholmod3.0.6:amd64 (1:4.4.6-1) ...
Setting up libcsparse3.1.4:amd64 (1:4.4.6-1) ...
Setting up libcxsparse3.1.4:amd64 (1:4.4.6-1) ...
Setting up libglpk36:amd64 (4.57-1build3) ...
Setting up libgmpxx4ldbl:amd64 (2:6.1.0+dfsg-2) ...
Setting up libgmp-dev:amd64 (2:6.1.0+dfsg-2) ...
Setting up libklu1.3.3:amd64 (1:4.4.6-1) ...
Setting up libldl2.2.1:amd64 (1:4.4.6-1) ...
Setting up libumfpack5.7.1:amd64 (1:4.4.6-1) ...
Setting up libspqr2.0.2:amd64 (1:4.4.6-1) ...
Setting up libsuitesparse-dev:amd64 (1:4.4.6-1) ...
Setting up libglpk-dev (4.57-1build3) ...
Processing triggers for libc-bin (2.23-0ubuntu10) ...
[2018-10-08T11:01:50.999891340+0000] Execute script: packages/build/units.sh
+ set -e
+ apt-get update -qq
+ apt-get install -y libudunits2-dev
Reading package lists...
Building dependency tree...
Reading state information...
The following additional packages will be installed:
  libudunits2-0
The following NEW packages will be installed:
  libudunits2-0 libudunits2-dev
0 upgraded, 2 newly installed, 0 to remove and 25 not upgraded.
Need to get 430 kB of archives.
After this operation, 992 kB of additional disk space will be used.
Get:1 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial/universe amd64 libudunits2-0 amd64 2.2.20-1 [69.5 kB]
Get:2 http://us-east-1.ec2.archive.ubuntu.com/ubuntu xenial/universe amd64 libudunits2-dev amd64 2.2.20-1 [360 kB]
debconf: delaying package configuration, since apt-utils is not installed
Fetched 430 kB in 0s (18.3 MB/s)
Selecting previously unselected package libudunits2-0:amd64.
(Reading database ... 119337 files and directories currently installed.)
Preparing to unpack .../libudunits2-0_2.2.20-1_amd64.deb ...
Unpacking libudunits2-0:amd64 (2.2.20-1) ...
Selecting previously unselected package libudunits2-dev.
Preparing to unpack .../libudunits2-dev_2.2.20-1_amd64.deb ...
Unpacking libudunits2-dev (2.2.20-1) ...
Processing triggers for libc-bin (2.23-0ubuntu10) ...
Setting up libudunits2-0:amd64 (2.2.20-1) ...
Setting up libudunits2-dev (2.2.20-1) ...
Processing triggers for libc-bin (2.23-0ubuntu10) ...
################################# End Task Log ################################# 
Erreur : Unhandled Exception: Child Task 555410290 error: Unhandled Exception: HTTP 599: Timeout during request
De plus : Warning message:
Error detecting locale: Error in read.table(file = file, header = header, sep = sep, quote = quote, : incomplete final line found by readTableHeader on 'raw'
 (Using default: en_US) 

I use Reactome.db from Bioconductor and I know by this post https://community.rstudio.com/t/error-599-timeout/9275 that another one user had the same problem by using this package, but he fix that by trying several times which has not worked in my case.

Any help would be greatly appreciated.

Quentin

> sessionInfo()
R version 3.5.1 (2018-07-02)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows >= 8 x64 (build 9200)

Matrix products: default

locale:
[1] LC_COLLATE=French_France.1252 
[2] LC_CTYPE=French_France.1252   
[3] LC_MONETARY=French_France.1252
[4] LC_NUMERIC=C                  
[5] LC_TIME=French_France.1252    

attached base packages:
[1] parallel  stats4    stats     graphics  grDevices
[6] utils     datasets  methods   base     

other attached packages:
 [1] shinyjs_1.0           shinyWidgets_0.4.3   
 [3] shinycssloaders_0.2.0 ggraph_1.0.2         
 [5] igraph_1.2.2          topGO_2.32.0         
 [7] SparseM_1.77          GO.db_3.6.0          
 [9] graph_1.58.0          org.Hs.eg.db_3.6.0   
[11] AnnotationDbi_1.42.1  markdown_0.8         
[13] Biobase_2.40.0        clusterProfiler_3.8.1
[15] ReactomePA_1.24.0     DT_0.4               
[17] ggplot2_3.0.0         dplyr_0.7.6          
[19] xlsx_0.6.1            shinydashboard_0.7.0 
[21] shiny_1.1.0           GenomicRanges_1.32.7 
[23] GenomeInfoDb_1.16.0   IRanges_2.14.12      
[25] S4Vectors_0.18.3      BiocGenerics_0.26.0  

loaded via a namespace (and not attached):
 [1] fgsea_1.6.0            colorspace_1.3-2      
 [3] ggridges_0.5.1         rsconnect_0.8.8       
 [5] qvalue_2.12.0          XVector_0.20.0        
 [7] rstudioapi_0.8         farver_1.0            
 [9] ggrepel_0.8.0          bit64_0.9-7           
[11] splines_3.5.1          GOSemSim_2.6.2        
[13] jsonlite_1.5           rJava_0.9-10          
[15] ggforce_0.1.3          graphite_1.26.2       
[17] compiler_3.5.1         httr_1.3.1            
[19] rvcheck_0.1.1          backports_1.1.2       
[21] assertthat_0.2.0       Matrix_1.2-14         
[23] lazyeval_0.2.1         later_0.7.5           
[25] tweenr_1.0.0           htmltools_0.3.6       
[27] tools_3.5.1            bindrcpp_0.2.2        
[29] gtable_0.2.0           glue_1.3.0            
[31] GenomeInfoDbData_1.1.0 reshape2_1.4.3        
[33] DO.db_2.9              rappdirs_0.3.1        
[35] fastmatch_1.1-0        Rcpp_0.12.19          
[37] enrichplot_1.0.2       RJSONIO_1.3-0         
[39] crosstalk_1.0.0        stringr_1.3.1         
[41] xlsxjars_0.6.1         mime_0.6              
[43] DOSE_3.6.1             zlibbioc_1.26.0       
[45] MASS_7.3-50            scales_1.0.0          
[47] BiocInstaller_1.30.0   reactome.db_1.64.0    
[49] promises_1.0.1         yaml_2.2.0            
[51] memoise_1.1.0          gridExtra_2.3         
[53] UpSetR_1.3.3           stringi_1.1.7         
[55] RSQLite_2.1.1          checkmate_1.8.5       
[57] BiocParallel_1.14.2    rlang_0.2.2           
[59] pkgconfig_2.0.2        bitops_1.0-6          
[61] matrixStats_0.54.0     lattice_0.20-35       
[63] purrr_0.2.5            bindr_0.1.1           
[65] htmlwidgets_1.3        cowplot_0.9.3         
[67] bit_1.1-14             tidyselect_0.2.4      
[69] plyr_1.8.4             magrittr_1.5          
[71] R6_2.3.0               DBI_1.0.0             
[73] pillar_1.3.0           withr_2.1.2           
[75] units_0.6-1            RCurl_1.95-4.11       
[77] tibble_1.4.2           crayon_1.3.4          
[79] viridis_0.5.1          grid_3.5.1            
[81] data.table_1.11.8      blob_1.1.1            
[83] digest_0.6.17          xtable_1.8-3          
[85] tidyr_0.8.1            httpuv_1.4.5          
[87] munsell_0.5.0          viridisLite_0.3.0 

#2

The reactome.db package is 2.5 GB uncompressed. When we attempt to build the application, we cache packages in re-compressed form and that is what is timing out here, at least from when I last looked in July.

You could try disabling package caching for your application and see if that helps you get past the issue.

We don't have an update at this time for a different work around.