I can access RStudio server on local browser but not from remotely

I'm trying to set up RStudio Server on CentOS 7.9. The installation and RStudio status seems fine:

(base) [root@localhost ~]# rstudio-server status
● rstudio-server.service - RStudio Server
   Loaded: loaded (/usr/lib/systemd/system/rstudio-server.service; enabled; vendor preset: disabled)
   Active: active (running) since Wed 2022-05-04 16:49:06 EDT; 16min ago
  Process: 82696 ExecStop=/usr/bin/killall -TERM rserver (code=exited, status=0/SUCCESS)
  Process: 82701 ExecStart=/usr/lib/rstudio-server/bin/rserver (code=exited, status=0/SUCCESS)
 Main PID: 82702 (rserver)
    Tasks: 12
   CGroup: /system.slice/rstudio-server.service
           ├─82702 /usr/lib/rstudio-server/bin/rserver
           └─82865 /usr/lib/rstudio-server/bin/rsession -u caim --session-use-secure-cookies 0 --session-root-path / --session-same-...

May 04 16:50:28 localhost.localdomain rsession-caim[82865]: INFO Set CRAN URL for session to 'https://cran.rstudio.com/' (sourc...ults)
May 04 16:50:32 localhost.localdomain rsession-caim[82865]: INFO No keybindings/addins.json found at /etc/rstudio/keybindings/a....json
May 04 16:50:32 localhost.localdomain rsession-caim[82865]: INFO No keybindings/rstudio_bindings.json found at /etc/rstudio/key....json
May 04 16:50:32 localhost.localdomain rsession-caim[82865]: INFO No keybindings/editor_bindings.json found at /etc/rstudio/keyb....json
May 04 16:55:28 localhost.localdomain rserver-pam[83970]: INFO Initializing crashpad client: handlerPath=/usr/lib/rstudio-serve...9247c
May 04 16:55:28 localhost.localdomain rserver-pam[83970]: pam_unix(rstudio:auth): authentication failure; logname= uid=0 euid=0...=caim
May 04 16:55:47 localhost.localdomain rserver-pam[84181]: INFO Initializing crashpad client: handlerPath=/usr/lib/rstudio-serve...9247c
May 04 16:55:54 localhost.localdomain rsession-caim[82865]: INFO No keybindings/addins.json found at /etc/rstudio/keybindings/a....json
May 04 16:55:54 localhost.localdomain rsession-caim[82865]: INFO No keybindings/rstudio_bindings.json found at /etc/rstudio/key....json
May 04 16:55:54 localhost.localdomain rsession-caim[82865]: INFO No keybindings/editor_bindings.json found at /etc/rstudio/keyb....json
Hint: Some lines were ellipsized, use -l to show in full.

I can also successfully open up the RStudio Server from my Linux terminal on my local computer via SSH using either of the following two commands (somehow the 8787 port does not work for me so I set the port to 80):

xdg-open http://localhost:80 # this works fine |
xdg-open http://<ip address>:80 # this also works

However, when I open up my local browser and type xdg-open http://<ip address>:80, I cannot access the RStudio Server. The web page reads "ERR_EMPTY_RESPONSE"

This page isn’t working right now
 <ip address> didn’t send any data.
ERR_EMPTY_RESPONSE

Is there any clue on this or anything I could try to tackle this problem? Any feedback would be greatly appreciated. Thanks!