I cant create new project due to [ (TypeError): Cannot read property 'python' of null ]

when I try to create new project, I receive an error (TypeError): Cannot read property 'python' of null.
OS: Windows 11
RStudio Version: 2022.07.01 554
R version: 4.2.1
RTools Version: 42

1 Like

Hi! @hamidreza
After, one week of trying to solve this problem I finally found the solution, at least for me.

First I reinstalled R, Rstudio, Rtools, Quarto, and Python, but the final solution was the below.

I copied the findstr.exe file from C:\Windows\System32 to C:\Program Files\RStudio\bin.

This solved not only the "create new project" problem but also the "render .qmd" file as well.

I hope it works for you as well.

1 Like

Thanks @Alencar .
Your solution solved my problem.
It solved "Create new project" & "Create new quatro document" & "create new quatro presentation" problem.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.