I can't load the package"hottopics" to R studio

Error Information:

Description of issue - package downlaod problem

Steps taken so far - I have upgraded my Rstudio version into R-3.5.3, but I sill can't download the package named"hottopics", which is a package of google trend.

System Information:


Downloading GitHub repo hrbrmstr/hottopic@master
Error in normalizePath(key$InstallPath, mustWork = FALSE, winslash = "/") :
file name conversion problem -- name too long?

I tried more than dozen times to install the package hottopic, but it still doesn't work and keep showing the same error result even though I unstall the old version and install the latest version of R and Rstudio.
what does it mean by file name conversion problem-name too long?
Did anyone face the same problem before? How can I handle with this?
Thank you!!

From Troubleshooting Guide: Using RStudio

This may imply the path that hottopic is attempting to use is too long, or R is otherwise unable to normalize it. Unfortunately, I'm not sure what the true underlying cause could be.

Can you share the output of:


However, the issue is likely independent of RStudio -- I suspect you may be able to reproduce the issue in e.g. RGui, so it may be something else.

Thanks for your response...here's the output.
so...it should be the problem of my computer rather than Rstudio.

The only thing surprising to me is that your R temporary directory lives within your public documents folder -- by default, the R temporary directory is in a folder like:


This is normally controlled by your system's environment variables; e.g. the TEMP or TMP environment variables. It's a shot in the dark, but perhaps worth investigating.

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.