IDE Terminal does not show icons from ZSH and powerlevel10k

IDE Terminal does not show icons

For some reason I have trouble selecting a custom font in the RStudio integrated terminal. I run macOS Monterey v12.4 on an M1 Max chip with ZSH 5.8.1 configured with the Powerlevel10K theme. I'm only allowed to post 1 image as a new user..

The terminal font is: SourceCodePro+Powerline+Awesome+Regular and I've downloaded the .tff file from a GitHub repo and installed this exact font in the Apple FontBook (for the Computer, not User!). Somehow the font does not show up in the RStudio IDE environment. I installed Source Code Pro earlier and that font family does show up in the RStudio options.

I am able to configure this SourceCodePro+Powerline+Awesome+Regular font in VSC but I've tried everything for R. I know... for sure not a big deal but I just bothers me that that one tiny detail looks off while working in R.

Anyone has any idea on how to fix this issue? Or how to approach it? Perhaps I should reconfigure powerlevel10k to another font...

Kind regards,
Max

Update
I was able to get this working in the daily build of the IDE by choosing a patched font in Preferences, e.g. see terminal window with FiraCodeNerdFontComplete selected below:

Old
If I use my default p10k setup in RStudio terminal (which also involves patched nerd fonts), I have the same result. I think this is due to the fact that not all fonts are supported in the IDE terminal (see, e.g. the issue from the IDE GitHub repo, below)

EDIT I can't actually figure out how to do what's suggested below for the RStudio terminal, as running echo $TERM_PROGRAM in the Terminal pane doesn't return anything.

You can disable/enable p10k in your zshrc based on what terminal program is being used (I do this for Warp, for example, which doesn't support powerlevel10k)

Not really a solution, but thought you might want to if the missing icons bug you.