Install ggalt from GitHub without Installing PROJ4

Hello, I've been in touch with Bob Rudis (caretaker of ggalt) and he graciously provided a method to install ggalt without the need for PROJ4 (see below):

devtools::install_github("hrbrmstr/ggalt", ref = "noproj")

Once I installed devtools package, I was unable to install the GitHub version of ggalt and got the following error message:

─ installing source package ‘ggalt’ ...
** ** using staged installation**
** ** R**
** ** inst**
** ** byte-compile and prepare package for lazy loading**
** Error in dyn.load(file, DLLpath = DLLpath, ...) : **
** unable to load shared object '/usr/local/lib/R/3.6/site-library/ash/libs/ash.so':**
** dlopen(/usr/local/lib/R/3.6/site-library/ash/libs/ash.so, 6): Library not loaded: /usr/local/opt/gcc/lib/gcc/8/libgfortran.5.dylib**
** Referenced from: /usr/local/lib/R/3.6/site-library/ash/libs/ash.so**
** Reason: image not found**
** Calls: ... namespaceImport -> loadNamespace -> library.dynam -> dyn.load**
** Execution halted**
** ERROR: lazy loading failed for package ‘ggalt’**
─ removing ‘/private/var/folders/gr/4hb6lcrn0zg8_1k9tcqkk6540000gn/T/RtmpDa1i0N/Rinst478c2f66461e/ggalt’
** -----------------------------------**
** ERROR: package installation failed**
Error: Failed to install 'ggalt' from GitHub:
** System command error, exit status: 1, stderr empty**

I tried forwarding the error message to Bob Rudis without a response. Can anyone help fix the problem of installing ggalt without PROJ4 using Bob's new ggalt package from GitHub.

Thanks,
Steve

I can't replicate your issue, are you choosing to update all the dependencies when asked by the installer?

remotes::install_github("hrbrmstr/ggalt", ref = "noproj")
Downloading GitHub repo hrbrmstr/ggalt@noproj
These packages have more recent versions available.
Which would you like to update?

1: All                              
2: CRAN packages only               
3: None                             
4: dplyr   (0.8.0.1 -> 0.8.3) [CRAN]
5: mime    (0.6     -> 0.7  ) [CRAN]
6: openssl (1.3     -> 1.4  ) [CRAN]

Enter one or more numbers, or an empty line to skip updates:
1

I you are no being asked to update packages then , it seems like you are having problems with your ash package installation, try reinstalling it with

install.packages("ash")