Hi All,
I tried to install "multcomp" package: (install.packages("multcomp")). But encountered the following error:

Warning in install.packages :
package ‘mvtnorm’ is not available (for R version 3.4.2)

Installing package into ‘C:/Users/npou797/Documents/R/win-library/3.4’
(as ‘lib’ is unspecified)
Warning in install.packages :
dependency ‘mvtnorm’ is not available

There is a binary version available but the source version is later:
binary source needs_compilation
multcomp 1.4-8 1.4-11 FALSE

installing the source package ‘multcomp’

trying URL ''
Content type 'application/x-gzip' length 603504 bytes (589 KB)
downloaded 589 KB

ERROR: dependency 'mvtnorm' is not available for package 'multcomp'

  • removing 'C:/Users/npou797/Documents/R/win-library/3.4/multcomp'
    Warning in install.packages :
    running command '"C:/PROGRA~1/R/R-34~1.2/bin/x64/R" CMD INSTALL -l "C:\Users\npou797\Documents\R\win-library\3.4" C:\Users\npou797\AppData\Local\Temp\RtmpOGjZYS/downloaded_packages/multcomp_1.4-11.tar.gz' had status 1
    Warning in install.packages :
    installation of package ‘multcomp’ had non-zero exit status

Note that my RStudio is the last version. I also tried installing "mvtnorm" first but the following has been shown:

Warning in install.packages :
package ‘mvtnorm’ is not available (for R version 3.4.2)

mvtnorm requires R >= 3.5.0 so you would have to update R in order to been able to install it

Its the latest version of RStudio

I opened a new page and now it is working!!!! Weird!!! Anyway, thanks.

Just to clarify, R and RStudio are two separate pieces of software, RStudio is an IDE for the R programming language, so both can have independent versions.

You can download the latest R version from here

Right. Thanks :slight_smile:

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.