Install system dependencies error for libgit2-dev and libcurl4-gnutls-dev on ubuntu-16.04

Hi,

I'm using Github Actions to run R CMD CHECK on an R package across several systems. This test is triggered on each push to the master branch and it seems to work on every system except for ubuntu-16.04 with R 4.0.0 (note that it previously worked on R 3.6.3 prior to this week's update).

Here is an example of a failed run.

The error message does not provide a reason as to why libcurl4-gnutls-dev cannot/will not be installed as a dependency. Any thoughts as to how I can fix this? Here is the workflow file for reference.

Thanks in advance!

Ah, I've filed the same question here with a bit more context (though I too don't know what I can do...):

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Thanks! For others viewing this post, I've followed the thread that yutannihilation linked to and a temporary solution is outlined here: https://github.com/r-hub/sysreqsdb/issues/77

1 Like