Installation of the adehabitatHR package


I am very new to R, and am having an issue installing adehabitatHR to run a home range analysis for work. When I ran the install.package("adehabitatHR") I got the same error as Anna3 did in her post: Installation of adehabitat
Warning in install.packages :
** package ‘adehabitatHR’ is not available for this version of R**
WARNING: Rtools is required to build R packages but is not currently installed. Please download and install the appropriate version of Rtools before proceeding:

Regaurding the first error I went to the online archive and downloaded the package offline and it is now in a folder on my C Drive. Yet unsure how to now install it into the system library.

Reguarding the second error I am unsure what to do as I am not sure exactly what Rtool to download.

Any help is very appreciated!
Thank you!

RTools: Toolchains for building R and R packages from source on Windows (
Choose your version of Rtools:

RTools 4.2 for R >= 4.2.0
RTools 4.0 for R from version 4.0.0 to 4.1.3
old versions of RTools for R versions prior to 4.0.0

If you are unsure of your R version. Run the following code in your R session


if you get major 4 then its one of the top 2 choices
depending on the minor
if you get major 3; then either go to the old versions ; or better yet, start over and gift yourself a more up-to-date version of R

Thank you for your response! I have version 4.2.1

I succesfully installed Rtools 4.2 through your link you gave me and I was able to download it which seemed to fix the error I was getting.

However I am still receiving the error (below) when I run the install.package(adehabitatHR). Not to mention I am also getting the same error when I try to install package rgdal, raster, and rgeos. All packages I need to run my home range analysis.

Warning in install.packages :
** unable to access index for repository**
Installing package into ‘C:/Users/SStromer/AppData/Local/R/win-library/4.2’
(as ‘lib’ is unspecified)
Warning in install.packages :
** unable to access index for repository**
Warning in install.packages :
** package ‘adehabitatHR’ is not available for this version of R

This seems like a connectivity issue, R is not being able to connect to the CRAN repository you have selected, these are some things to try.

  • Choose a different CRAN repository, RStudios repository is a good choice ( or you could choose one that is geographically closer to you.
  • Disable secure download setting.
  • Check if your internet connection has traffic restrictions of some kind, like a firewall, proxy server, etc. This is usually the case when you are at work or school.

Thank you so much for your help! This community is so helpful!

I got the adehabitatHR package to download. I used CRAN respository Oregon State Univeristy, and I do think it was my protected internet. I was on a VPN for work and logged out of that.

I tried all my other packages I needed, and they all downloaded as well.

Im so happy. Thanks again. I am sure I will be back!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.